summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild7
-rw-r--r--media-sound/bluez-alsa/metadata.xml1
2 files changed, 6 insertions, 2 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index c8620648df98..86a703524a0e 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="aac debug hcitop lame ldac man mpg123 ofono static-libs test unwind upower"
+IUSE="aac aptx debug hcitop lame ldac man mpg123 ofono static-libs test unwind upower"
RESTRICT="!test? ( test )"
# bluez-alsa does not directly link to upower but
@@ -30,6 +30,7 @@ RDEPEND="
sys-apps/dbus[${MULTILIB_USEDEP}]
sys-libs/readline:0=
aac? ( >=media-libs/fdk-aac-0.1.1:=[${MULTILIB_USEDEP}] )
+ aptx? ( media-libs/libopenaptx )
lame? ( media-sound/lame[${MULTILIB_USEDEP}] )
mpg123? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
hcitop? (
@@ -63,10 +64,12 @@ multilib_src_configure() {
$(use_enable mpg123)
$(use_enable static-libs static)
$(use_enable test)
+ $(multilib_native_use_enable aptx)
$(multilib_native_use_enable hcitop)
$(multilib_native_use_enable ldac)
$(multilib_native_use_enable ofono)
$(multilib_native_use_enable upower)
+ $(multilib_native_use_with aptx libopenaptx)
$(use_with unwind libunwind)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
diff --git a/media-sound/bluez-alsa/metadata.xml b/media-sound/bluez-alsa/metadata.xml
index 55feec0ee5bc..e23255b68bfd 100644
--- a/media-sound/bluez-alsa/metadata.xml
+++ b/media-sound/bluez-alsa/metadata.xml
@@ -9,6 +9,7 @@
<remote-id type="github">Arkq/bluez-alsa</remote-id>
</upstream>
<use>
+ <flag name="aptx">aptX (HD) over Bluetooth (many Android compatible headphones)</flag>
<flag name="hcitop">Enable top-like monitoring tool for HCI</flag>
<flag name="ldac">Enable support for AOSP <pkg>media-libs/libldac</pkg> dispatcher</flag>
<flag name="mpg123">Enable support for MPEG audio playback via <pkg>media-sound/mpg123</pkg></flag>