summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/eom/Manifest1
-rw-r--r--media-gfx/eom/eom-1.10.5-r1.ebuild84
-rw-r--r--media-gfx/eom/files/eom-1.10-fix-introspection.patch169
3 files changed, 254 insertions, 0 deletions
diff --git a/media-gfx/eom/Manifest b/media-gfx/eom/Manifest
index 143b9e0204b3..dbd0f2b91405 100644
--- a/media-gfx/eom/Manifest
+++ b/media-gfx/eom/Manifest
@@ -1,2 +1,3 @@
+DIST eom-1.10.5.tar.xz 2207424 SHA256 19b484dba1c2adf1450153815e4edb05ba7ab7bdf4eb8b4f2071766e48e72d14 SHA512 f58f2c4c1d211afe66c2a112b75ee6b325590294da51df3a56d1dca0fb813cea1abd9e9dc7a4a3f26c111f1c11aba20e8177e36913f04bae664f4ddad6f98c0c WHIRLPOOL 1ce95839628e51060f2c77e8a701046754817870f998a6388aa620e12470b2e690e11edd5e7770303da33103f0077a3726eba01bd537a2cc3729bbd29dbc92d0
DIST eom-1.8.0.tar.xz 2190980 SHA256 ec8450bf2ebef13c2e376b1674f0f7402f87669a71eb9e2e4d1161a2784aaf9e SHA512 cc9d82ec164043653eae2f73a0b7896c0d09b2eb466a5c919b0e1df732dd18fff58fa978d01a9bbb2bb7b8427c11328affb3f4e6aeb18a77a18585f39a1f3f5a WHIRLPOOL 26c091d74a8a052a4ce1e0295e41d75bb14ed1d93024367f63214139624d61b74fdd74fc66ee02a472f7d7494cbcfa9aac4e1762f1057432f7afd5db1cf0e515
DIST eom-1.8.1.tar.xz 2192220 SHA256 d8c97de2aab548dce910cdfd98a11b671c943e9b195d38b043e482e2323ac6d8 SHA512 e054286eebdc88390dd8855d6b43704d4bc5d0b7d69f0dc73108d26e75882ee13bfaec01a30dbc42cee14e10ca42eeb9a6f576fe8435055ba289fe2292f97837 WHIRLPOOL 10856132756b1ea7ab9be23547d94968fcce3183528cb0d656c9cd307108fe8623a70a7ee53c85db6ef74a333691ffcf1210f8c9885db4a31b63713d8924c0d9
diff --git a/media-gfx/eom/eom-1.10.5-r1.ebuild b/media-gfx/eom/eom-1.10.5-r1.ebuild
new file mode 100644
index 000000000000..731c3b38ef3e
--- /dev/null
+++ b/media-gfx/eom/eom-1.10.5-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 autotools python-single-r1 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="The MATE image viewer"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X dbus exif +introspection jpeg lcms python svg tiff xmp"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2:2
+ gnome-base/dconf:0
+ >=mate-base/mate-desktop-1.10:0
+ sys-libs/zlib:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.4:2[introspection?,jpeg?,tiff?]
+ >=x11-libs/gtk+-2.18:2[introspection?]
+ x11-libs/libX11:0
+ >=x11-misc/shared-mime-info-0.20:0
+ >=x11-themes/mate-icon-theme-1.10:0
+ virtual/libintl:0
+ dbus? ( >=dev-libs/dbus-glib-0.71:0 )
+ exif? (
+ >=media-libs/libexif-0.6.14:0
+ virtual/jpeg:0 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.15.1:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13:2[${PYTHON_USEDEP}] )
+ svg? ( >=gnome-base/librsvg-2.36.2:2 )
+ xmp? ( >=media-libs/exempi-1.99.5:2 )
+ !!media-gfx/mate-image-viewer"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/eom-1.10-fix-introspection.patch"
+ eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_with jpeg libjpeg) \
+ $(use_with exif libexif) \
+ $(use_with dbus) \
+ $(use_with lcms cms) \
+ $(use_with xmp) \
+ $(use_with svg librsvg) \
+ $(use_with X x) \
+ --without-cms
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
diff --git a/media-gfx/eom/files/eom-1.10-fix-introspection.patch b/media-gfx/eom/files/eom-1.10-fix-introspection.patch
new file mode 100644
index 000000000000..71e20ea02ccb
--- /dev/null
+++ b/media-gfx/eom/files/eom-1.10-fix-introspection.patch
@@ -0,0 +1,169 @@
+From 3d34cc10a5e62686f661a6653d43e2c42e6a26a2 Mon Sep 17 00:00:00 2001
+From: Sorokin Alexei <sor.alexei@meowr.ru>
+Date: Sat, 12 Dec 2015 16:49:22 +0300
+Subject: [PATCH] Fix compilation with enabled GObject Introspection
+
+---
+ configure.ac | 2 ++
+ src/main.c | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9b829d0..b3d398f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -142,6 +142,8 @@ else
+ have_introspection=no
+ fi
+
++AM_CONDITIONAL(HAVE_INTROSPECTION, test "x$have_introspection" = xyes)
++
+ # ***************
+ # ZLIB (required)
+ # ***************
+diff --git a/src/main.c b/src/main.c
+index cc999e2..f1b92f7 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -30,7 +30,7 @@
+ #include <dbus/dbus-glib-bindings.h>
+ #include <gdk/gdkx.h>
+ #endif
+-#ifdef HAVE_INSTROSPECTION
++#ifdef HAVE_INTROSPECTION
+ #include <girepository.h>
+ #endif
+
+From d6f68de8ed0722fdfecca9f81d68f2a0ff9b82bd Mon Sep 17 00:00:00 2001
+From: Wolfgang Ulbrich <chat-to-me@raveit.de>
+Date: Sun, 6 Dec 2015 23:58:24 +0100
+Subject: [PATCH] fix some gobject-introspection build warnings
+
+---
+ src/uta.c | 30 ++++++++++++++----------------
+ 1 file changed, 14 insertions(+), 16 deletions(-)
+
+diff --git a/src/uta.c b/src/uta.c
+index 8df97bc..c44834d 100644
+--- a/src/uta.c
++++ b/src/uta.c
+@@ -38,9 +38,7 @@
+ be variables. They can also be pstruct->el lvalues. */
+ #define eom_expand(p, type, max) do { if(max) { p = eom_renew (p, type, max <<= 1); } else { max = 1; p = g_new(type, 1); } } while (0)
+
+-
+-
+-/**
++/*
+ * eom_uta_new: Allocate a new uta.
+ * @x0: Left coordinate of uta.
+ * @y0: Top coordinate of uta.
+@@ -51,7 +49,7 @@
+ * tiles, not pixels.
+ *
+ * Returns: the newly allocated #EomUta.
+- **/
++ */
+ static EomUta *
+ eom_uta_new (int x0, int y0, int x1, int y1)
+ {
+@@ -68,13 +66,13 @@ eom_uta_new (int x0, int y0, int x1, int y1)
+ return uta;
+ }
+
+-/**
++/*
+ * eom_uta_free: Free a uta.
+ * @uta: The uta to free.
+ *
+ * Frees the microtile array structure, including the actual microtile
+ * data.
+- **/
++ */
+ void
+ eom_uta_free (EomUta *uta)
+ {
+@@ -82,14 +80,14 @@ eom_uta_free (EomUta *uta)
+ g_free (uta);
+ }
+
+-/**
++/*
+ * eom_irect_intersect: Find intersection of two integer rectangles.
+ * @dest: Where the result is stored.
+ * @src1: A source rectangle.
+ * @src2: Another source rectangle.
+ *
+ * Finds the intersection of @src1 and @src2.
+- **/
++ */
+ void
+ eom_irect_intersect (EomIRect *dest, const EomIRect *src1, const EomIRect *src2) {
+ dest->x0 = MAX (src1->x0, src2->x0);
+@@ -98,18 +96,18 @@ eom_irect_intersect (EomIRect *dest, const EomIRect *src1, const EomIRect *src2)
+ dest->y1 = MIN (src1->y1, src2->y1);
+ }
+
+-/**
++/*
+ * eom_irect_empty: Determine whether integer rectangle is empty.
+ * @src: The source rectangle.
+ *
+ * Return value: TRUE if @src is an empty rectangle, FALSE otherwise.
+- **/
++ */
+ int
+ eom_irect_empty (const EomIRect *src) {
+ return (src->x1 <= src->x0 || src->y1 <= src->y0);
+ }
+
+-/**
++/*
+ * eom_uta_from_irect: Generate uta covering a rectangle.
+ * @bbox: The source rectangle.
+ *
+@@ -117,7 +115,7 @@ eom_irect_empty (const EomIRect *src) {
+ * function with a @bbox with zero height or width.
+ *
+ * Return value: the new uta.
+- **/
++ */
+ static EomUta *
+ eom_uta_from_irect (EomIRect *bbox)
+ {
+@@ -217,7 +215,7 @@ eom_uta_from_irect (EomIRect *bbox)
+ * big enough to fit the specified microtile coordinates, or a new array if
+ * it needed to be grown. In the second case, the original @uta will be
+ * freed automatically.
+- **/
++ */
+ EomUta *
+ uta_ensure_size (EomUta *uta, int x1, int y1, int x2, int y2)
+ {
+@@ -284,7 +282,7 @@ uta_ensure_size (EomUta *uta, int x1, int y1, int x2, int y2)
+ * Return value: The original @uta, or a new microtile array if the original one
+ * needed to be grown to fit the specified rectangle. In the second case, the
+ * original @uta will be freed automatically.
+- **/
++ */
+ EomUta *
+ uta_add_rect (EomUta *uta, int x1, int y1, int x2, int y2)
+ {
+@@ -552,7 +550,7 @@ uta_add_rect (EomUta *uta, int x1, int y1, int x2, int y2)
+ * Removes a rectangular region from the specified microtile array. Due to the
+ * way microtile arrays represent regions, the tiles at the edge of the
+ * rectangle may not be clipped exactly.
+- **/
++ */
+ void
+ uta_remove_rect (EomUta *uta, int x1, int y1, int x2, int y2)
+ {
+@@ -1047,7 +1045,7 @@ copy_tile (EomUta *uta, int x, int y, int xofs, int yofs)
+ * expanded if the destination area does not fit within it; rather only the area
+ * that fits will be copied. The source rectangle must be completely contained
+ * within the microtile array.
+- **/
++ */
+ void
+ uta_copy_area (EomUta *uta, int src_x, int src_y, int dest_x, int dest_y, int width, int height)
+ {