summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.380.0.ebuild4
-rw-r--r--dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.490.0.ebuild1
-rw-r--r--dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.200.ebuild1
-rw-r--r--dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.380.0-no-dot-inc.patch37
-rw-r--r--dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.490.0-no-dot-inc.patch37
-rw-r--r--dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.600.200-no-dot-inc.patch51
6 files changed, 129 insertions, 2 deletions
diff --git a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.380.0.ebuild b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.380.0.ebuild
index 3c7fdfc922fa..645f570866cd 100644
--- a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.380.0.ebuild
+++ b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.380.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,5 +16,5 @@ IUSE=""
RDEPEND=">=virtual/perl-Math-BigInt-1.999.300
>=dev-libs/gmp-4.0.0:0"
DEPEND="${RDEPEND}"
-
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
SRC_TEST="do"
diff --git a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.490.0.ebuild b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.490.0.ebuild
index 0c69b17967fc..6f3fd80ddaa4 100644
--- a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.490.0.ebuild
+++ b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.490.0.ebuild
@@ -22,3 +22,4 @@ DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? ( >=virtual/perl-Test-Simple-0.470.0 )
"
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
diff --git a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.200.ebuild b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.200.ebuild
index 667b952726d9..4a1cbfa86ae4 100644
--- a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.200.ebuild
+++ b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.600.200.ebuild
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? ( >=virtual/perl-Test-Simple-0.820.0 )
"
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
src_test() {
perl_rm_files t/author-*.t t/00sig.t t/02pod.t t/03podcov.t
perl-module_src_test
diff --git a/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.380.0-no-dot-inc.patch b/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.380.0-no-dot-inc.patch
new file mode 100644
index 000000000000..96e7f88d3e14
--- /dev/null
+++ b/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.380.0-no-dot-inc.patch
@@ -0,0 +1,37 @@
+From 4a57ce8560c39b71ba6b8220a63efcbf5aac82ea Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Mon, 30 Oct 2017 21:42:48 +1300
+Subject: Fix test failures without '.' in @INC
+
+Under PERL_USE_UNSAFE_INC=0
+
+Bug: https://bugs.gentoo.org/613642
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120718
+---
+ t/bigfltpm.t | 2 +-
+ t/bigintpm.t | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/t/bigfltpm.t b/t/bigfltpm.t
+index de3c80e..89dea16 100644
+--- a/t/bigfltpm.t
++++ b/t/bigfltpm.t
+@@ -26,4 +26,4 @@ my $e = $c->bdiv(Math::BigFloat->new(3),$d);
+ is ($e,'0.00267'); # '0.008 / 3 => 0.0027');
+ is (ref($e->{_e}->[0]), ''); # 'Not a BigInt');
+
+-require 't/bigfltpm.inc'; # all tests here for sharing
++require './t/bigfltpm.inc'; # all tests here for sharing
+diff --git a/t/bigintpm.t b/t/bigintpm.t
+index 8f009ec..c05f135 100644
+--- a/t/bigintpm.t
++++ b/t/bigintpm.t
+@@ -33,4 +33,4 @@ is ($x, "9903520314281112085086151826", 'from_oct() works with big numbers');
+ #############################################################################
+ # all the other tests
+
+-require 't/bigintpm.inc'; # all tests here for sharing
++require './t/bigintpm.inc'; # all tests here for sharing
+--
+2.14.3
+
diff --git a/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.490.0-no-dot-inc.patch b/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.490.0-no-dot-inc.patch
new file mode 100644
index 000000000000..24c271ea6076
--- /dev/null
+++ b/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.490.0-no-dot-inc.patch
@@ -0,0 +1,37 @@
+From edaedb9078d56f4f86cdb7eb9160deeb3196f164 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Mon, 30 Oct 2017 21:42:48 +1300
+Subject: Fix test failures without '.' in @INC
+
+Under PERL_USE_UNSAFE_INC=0
+
+Bug: https://bugs.gentoo.org/613642
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120718
+---
+ t/bigfltpm.t | 2 +-
+ t/bigintpm.t | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/t/bigfltpm.t b/t/bigfltpm.t
+index 0e89852..0af20f4 100644
+--- a/t/bigfltpm.t
++++ b/t/bigfltpm.t
+@@ -33,4 +33,4 @@ SKIP: {
+ is(ref($e->{_e}->[0]), '', '$e->{_e}->[0] is a scalar');
+ }
+
+-require 't/bigfltpm.inc'; # all tests here for sharing
++require './t/bigfltpm.inc'; # all tests here for sharing
+diff --git a/t/bigintpm.t b/t/bigintpm.t
+index 03dee01..1ebf230 100644
+--- a/t/bigintpm.t
++++ b/t/bigintpm.t
+@@ -44,4 +44,4 @@ is($x, "9903520314281112085086151826",
+ #############################################################################
+ # all the other tests
+
+-require 't/bigintpm.inc'; # all tests here for sharing
++require './t/bigintpm.inc'; # all tests here for sharing
+--
+2.14.3
+
diff --git a/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.600.200-no-dot-inc.patch b/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.600.200-no-dot-inc.patch
new file mode 100644
index 000000000000..2f0158befcae
--- /dev/null
+++ b/dev-perl/Math-BigInt-GMP/files/Math-BigInt-GMP-1.600.200-no-dot-inc.patch
@@ -0,0 +1,51 @@
+From 74cf47cac322f4399cea78bf7cdb75769578c035 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Mon, 30 Oct 2017 21:42:48 +1300
+Subject: Fix test failures without '.' in @INC
+
+Under PERL_USE_UNSAFE_INC=0
+
+Bug: https://bugs.gentoo.org/613642
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120718
+---
+ t/bigfltpm.t | 2 +-
+ t/bigintpm.t | 2 +-
+ t/mbimbf.t | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/t/bigfltpm.t b/t/bigfltpm.t
+index 49c3744..30f2d84 100644
+--- a/t/bigfltpm.t
++++ b/t/bigfltpm.t
+@@ -72,4 +72,4 @@ SKIP: {
+ is(ref($e->{_e}->[0]), '', '$e->{_e}->[0] is a scalar');
+ }
+
+-require 't/bigfltpm.inc'; # all tests here for sharing
++require './t/bigfltpm.inc'; # all tests here for sharing
+diff --git a/t/bigintpm.t b/t/bigintpm.t
+index 8351bc6..a82476f 100644
+--- a/t/bigintpm.t
++++ b/t/bigintpm.t
+@@ -78,4 +78,4 @@ is($x, "9903520314281112085086151826",
+ #############################################################################
+ # all the other tests
+
+-require 't/bigintpm.inc'; # all tests here for sharing
++require './t/bigintpm.inc'; # all tests here for sharing
+diff --git a/t/mbimbf.t b/t/mbimbf.t
+index 668508e..6b4194e 100644
+--- a/t/mbimbf.t
++++ b/t/mbimbf.t
+@@ -15,7 +15,7 @@ use Math::BigFloat;
+ our $mbi = 'Math::BigInt';
+ our $mbf = 'Math::BigFloat';
+
+-require 't/mbimbf.inc';
++require './t/mbimbf.inc';
+
+ # some tests that won't work with subclasses, since the things are only
+ # guaranteed in the Math::Big(Int|Float) (unless subclass chooses to support
+--
+2.14.3
+