summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2022.8.19.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index c79e93d01374..377a335e50e8 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2022.8.14.tar.gz 2368444 BLAKE2B 77994eabc7832ee75b397fbd3d7a37b4fc3cfda2e092e3410656bf303618b2bc6f65eeffe1c99b21e80233f7ddf4ade72debbf5151eb68a0e0e87c512917626f SHA512 5a2219d55fb4f02c2f22eb6bf11d9986c75613401c3b8f7f8d39e6a5a534cb91f5c27fbf735919c414c3d7f193024315eb3eee02a1743828bdcf9b102a748cee
+DIST yt-dlp-2022.8.19.tar.gz 2373949 BLAKE2B c95aabee39ebf4a9285f05e17f85c6fcdb2d7ddc07bc9866e59f55cbbc10bbbb048d22d6dda434eae8383834308e29c959e47ed40d07d20296ead8ad09efb999 SHA512 277a91f4790d7bc34f913e420d3c8b1c563a6a88e6175077cdbf53c60d05afaae56b4103acfc3725015e5075fc1346194e06a81d1d68de743d7173265cb39d25
diff --git a/net-misc/yt-dlp/yt-dlp-2022.8.19.ebuild b/net-misc/yt-dlp/yt-dlp-2022.8.19.ebuild
new file mode 100644
index 000000000000..705a62db9da4
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2022.8.19.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 ~riscv x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}