summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/alternate/alternate-2.18-r1.ebuild27
-rw-r--r--app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch4
2 files changed, 29 insertions, 2 deletions
diff --git a/app-vim/alternate/alternate-2.18-r1.ebuild b/app-vim/alternate/alternate-2.18-r1.ebuild
new file mode 100644
index 000000000000..9e10a920cc26
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=31"
+
+LICENSE="alternate"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hh-cc-alternation.patch
+)
+
+src_prepare() {
+ default
+}
diff --git a/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch b/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch
index 3ea591e1e2fe..14b314aa0e0c 100644
--- a/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch
+++ b/app-vim/alternate/files/alternate-2.18-hh-cc-alternation.patch
@@ -1,5 +1,5 @@
---- plugin/a.vim 2005-05-06 22:20:24.000000000 +0100
-+++ plugin/a.vim 2005-06-20 15:45:45.000000000 +0100
+--- a/plugin/a.vim 2005-05-06 22:20:24.000000000 +0100
++++ b/plugin/a.vim 2005-06-20 15:45:45.000000000 +0100
@@ -57,13 +57,14 @@
" Mappings for C and C++
call <SID>AddAlternateExtensionMapping('h',"c,cpp,cxx,cc,CC")