summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/yaboot/files/chrpfix.patch4
-rw-r--r--sys-boot/yaboot/files/new-ofpath-devspec.patch4
-rw-r--r--sys-boot/yaboot/files/yaboot-stubfuncs.patch8
3 files changed, 8 insertions, 8 deletions
diff --git a/sys-boot/yaboot/files/chrpfix.patch b/sys-boot/yaboot/files/chrpfix.patch
index e64369ba899a..59ea7a072633 100644
--- a/sys-boot/yaboot/files/chrpfix.patch
+++ b/sys-boot/yaboot/files/chrpfix.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2004-03-22 12:04:32.056149336 -0600
-+++ Makefile 2004-03-22 12:05:51.824138328 -0600
+--- a/Makefile.orig 2004-03-22 12:04:32.056149336 -0600
++++ b/Makefile 2004-03-22 12:05:51.824138328 -0600
@@ -103,9 +103,11 @@
all: yaboot addnote mkofboot
diff --git a/sys-boot/yaboot/files/new-ofpath-devspec.patch b/sys-boot/yaboot/files/new-ofpath-devspec.patch
index ac03c15d8dd7..e9ad749d8f06 100644
--- a/sys-boot/yaboot/files/new-ofpath-devspec.patch
+++ b/sys-boot/yaboot/files/new-ofpath-devspec.patch
@@ -1,5 +1,5 @@
---- ybin/ofpath.bak 2012-05-09 12:24:51.709911981 -0400
-+++ ybin/ofpath 2012-05-09 12:32:19.661560544 -0400
+--- a/ybin/ofpath.bak 2012-05-09 12:24:51.709911981 -0400
++++ b/ybin/ofpath 2012-05-09 12:32:19.661560544 -0400
@@ -85,11 +85,20 @@
[ "$DEBUG" = 1 ] && echo "Devpath is: $DEVPATH"
diff --git a/sys-boot/yaboot/files/yaboot-stubfuncs.patch b/sys-boot/yaboot/files/yaboot-stubfuncs.patch
index 8ae522b7d4eb..ba6fcc7b3606 100644
--- a/sys-boot/yaboot/files/yaboot-stubfuncs.patch
+++ b/sys-boot/yaboot/files/yaboot-stubfuncs.patch
@@ -1,7 +1,7 @@
Stub out some functions that are not provided (and unneeded)
---- lib/malloc.c
-+++ lib/malloc.c
+--- a/lib/malloc.c
++++ b/lib/malloc.c
@@ -64,6 +64,15 @@ void *malloc (unsigned int size)
return caddr;
}
@@ -18,8 +18,8 @@ Stub out some functions that are not provided (and unneeded)
/* Do not fall back to the malloc above as posix_memalign is needed by
* external libraries not yaboot */
int posix_memalign(void **memptr, size_t alignment, size_t size)
---- lib/nonstd.c
-+++ lib/nonstd.c
+--- a/lib/nonstd.c
++++ b/lib/nonstd.c
@@ -65,3 +65,208 @@
{
return NULL;