summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/naught/naught-1.1.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/naught/naught-1.1.0-r1.ebuild b/dev-ruby/naught/naught-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..ebda1f6d4c44
--- /dev/null
+++ b/dev-ruby/naught/naught-1.1.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building Null Objects in Ruby"
+HOMEPAGE="https://github.com/avdi/naught"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}