summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/llvm-vim/Manifest1
-rw-r--r--app-vim/llvm-vim/llvm-vim-4.0.0_rc1.ebuild25
-rw-r--r--app-vim/llvm-vim/llvm-vim-9999.ebuild29
-rw-r--r--app-vim/llvm-vim/metadata.xml7
-rw-r--r--profiles/package.mask1
5 files changed, 63 insertions, 0 deletions
diff --git a/app-vim/llvm-vim/Manifest b/app-vim/llvm-vim/Manifest
new file mode 100644
index 000000000000..776e06d97a9a
--- /dev/null
+++ b/app-vim/llvm-vim/Manifest
@@ -0,0 +1 @@
+DIST llvm-4.0.0rc1.src.tar.xz 20996760 SHA256 ccbff3a7af78efc12b5b7f749d184b4c8caf75621af4e05f640cbfa9f80f8604 SHA512 10b6fee561b9307490d5f20ce70b7e0099bd405e56c8330be9aa04673f39dbd712833e357a577a5106819336a1957dd73d288bbdd35286d56305d14d237dfd3d WHIRLPOOL 8559852df5d036a4d86a4555bcbeaab6bbb3b5e9cad9daa8c0f5e934e4fb7235bc05df55e09d38eb4d90832036d8b9f5b1ff8108e7d5ea01c86b00eecc0a3d13
diff --git a/app-vim/llvm-vim/llvm-vim-4.0.0_rc1.ebuild b/app-vim/llvm-vim/llvm-vim-4.0.0_rc1.ebuild
new file mode 100644
index 000000000000..a11c65b20bb2
--- /dev/null
+++ b/app-vim/llvm-vim/llvm-vim-4.0.0_rc1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Vim support files for LLVM"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://www.llvm.org/pre-releases/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/llvm-${PV/_/}.src/utils/vim
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ dodoc README vimrc
+}
diff --git a/app-vim/llvm-vim/llvm-vim-9999.ebuild b/app-vim/llvm-vim/llvm-vim-9999.ebuild
new file mode 100644
index 000000000000..8d0fc67d3c66
--- /dev/null
+++ b/app-vim/llvm-vim/llvm-vim-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Vim support files for LLVM"
+HOMEPAGE="http://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="http://llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/${P}/utils/vim
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ dodoc README vimrc
+}
diff --git a/app-vim/llvm-vim/metadata.xml b/app-vim/llvm-vim/metadata.xml
new file mode 100644
index 000000000000..89c4bdb96049
--- /dev/null
+++ b/app-vim/llvm-vim/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>llvm@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 8ffdd959176c..62328f2e013f 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -252,6 +252,7 @@ x11-drivers/xf86-video-v4l
# Michał Górny <mgorny@gentoo.org> (24 Jan 2017)
# Mask 4.0.0 RCs (then final) for initial testing, and updating most
# important revdeps. Also revdeps that require 4.0.
+=app-vim/llvm-vim-4.0.0*
=dev-ml/llvm-ocaml-4.0.0*
=dev-python/lit-4.0.0*
=dev-util/lldb-4.0.0*