summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libprotoident/Manifest1
-rw-r--r--net-libs/libprotoident/libprotoident-2.0.9.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/libprotoident/Manifest b/net-libs/libprotoident/Manifest
index 04bf1a9a2d0f..5a0336d2f452 100644
--- a/net-libs/libprotoident/Manifest
+++ b/net-libs/libprotoident/Manifest
@@ -1,2 +1,3 @@
DIST libprotoident-2.0.7.tar.gz 483119 SHA256 5063497274e546b01b0606c8906a292cbe1e2ba8d6f3b6cd25de16a91fef635e SHA512 0491a2c67f1cd43dc82d68f8d6d3d6c423a7ba6ce07141107b9f50c08b858974c504dcf563501b3f33c29e799baa88871444f12ebf5f6c70adc73c08824dced8 WHIRLPOOL 37c9eecd5f3ba81d02d849aebeab05b21e26c0e0e58718a55841c500c9c33faf3cecac5d564a619a2aaf7d5c4e703297997f8e45d575d846ca9c1c6a34e8f6d6
DIST libprotoident-2.0.8.tar.gz 521527 SHA256 eb7ca6a4488084e669dfecc65151e0f3defa4e9a5a6296f7ac436afac045e527 SHA512 6c62c70117849aef2e5ae66646c5c8ea63db739cdeb7ee8cdf715c25b06f0916de9ba707a971ca2e7d2770b2b5e13e22bab31b5ccfff734b1429a1946f46d37c WHIRLPOOL 1b030485b9e94cce8730019bfb86c6ff629b165ce49628c2fab09d1638a5f85a3fd568cf4753b05eb567323409b9eebe64d009cc4005b2c8e99d370dc26cd720
+DIST libprotoident-2.0.9.tar.gz 532743 SHA256 da8c68e6e792285346c5a5c9fa64d03536662c4a11b192fb05ea6cc013d1dfe6 SHA512 480508bf3b40ca9c18d35d888a18b476437cc79988fa9476fa04f45d0764752a41c02436a47d873fe6be977eedc7e870f1bd1da3edae526322247d33d8de204b WHIRLPOOL 838603801ae7064ea0d45887e556a6bd5289f31870806c76b56718d6f30cb6ab61cc7c2ca7158383271eafe85b676d50f2db9070443f57a3d3af580db57aa797
diff --git a/net-libs/libprotoident/libprotoident-2.0.9.ebuild b/net-libs/libprotoident/libprotoident-2.0.9.ebuild
new file mode 100644
index 000000000000..9b6e6006d607
--- /dev/null
+++ b/net-libs/libprotoident/libprotoident-2.0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A library that performs application layer protocol identification for flows"
+HOMEPAGE="http://research.wand.net.nz/software/libprotoident.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs +tools"
+
+DEPEND="
+ >=net-libs/libtrace-3.0.9
+ tools? ( net-libs/libflowmanager )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}