summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-games/hdl_dump/Manifest1
-rw-r--r--dev-games/hdl_dump/files/Makefile.patch38
-rw-r--r--dev-games/hdl_dump/hdl_dump-0.9.2.20180722.ebuild41
-rw-r--r--dev-games/hdl_dump/metadata.xml11
4 files changed, 87 insertions, 4 deletions
diff --git a/dev-games/hdl_dump/Manifest b/dev-games/hdl_dump/Manifest
index a35f446eabea..2a84ffeb793b 100644
--- a/dev-games/hdl_dump/Manifest
+++ b/dev-games/hdl_dump/Manifest
@@ -1 +1,2 @@
+DIST hdl_dump-0.9.2.20180722.tar.gz 185864 BLAKE2B cf8ff790f418d8905b0e0fbab1bcb52d8f9bb73f2a5d0dd7320c97c38a0b87800bb6ad778ebf3345d71d1f4ea2c6a6fd9a9ed0da73082fd774231568ac9fab45 SHA512 e70ae10425679dd7eab7fae51a3dd2355b2e2ef9a3de83f313bfb437407b47c4482759799a4b81cf0b86ae852eb64ab8b30aeca9443f511e5ff1e34e1fbc30e3
DIST hdl_dumx-0.8.6-20060901-src.tar.bz2 156322 BLAKE2B f05ce1ccc10e23980ec24d75555bc609b913b0d2c32606b2eb616a7721d7c11ceee6c2a3b8e8bd9020c1747dfb8d514d4924798a512e11e606249c5a8725c45d SHA512 c54c72c3f4d57ca8f3299c0b6044ec5376504f7b7a4c7977d71b996bc8d98577ffa868891e1a599aebbe58b8d3ccf2513c5cf8a47350c0b0f53fd21a0e64bbc8
diff --git a/dev-games/hdl_dump/files/Makefile.patch b/dev-games/hdl_dump/files/Makefile.patch
new file mode 100644
index 000000000000..d1527676d9db
--- /dev/null
+++ b/dev-games/hdl_dump/files/Makefile.patch
@@ -0,0 +1,38 @@
+diff -Naur a/Makefile b/Makefile
+--- a/Makefile 2017-01-30 21:48:47.000000000 +0000
++++ b/Makefile 2018-07-21 23:12:11.829945396 +0100
+@@ -48,9 +48,8 @@
+ ###############################################################################
+
+
+-CFLAGS = -Wall -ansi -pedantic -Wno-long-long
++CFLAGS += -Wall -ansi -pedantic -Wno-long-long
+
+-LDFLAGS =
+
+ # iin_hdloader.c iin_net.c
+ SOURCES = hdl_dump.c \
+@@ -106,11 +105,11 @@
+ DEBUG = no
+ endif
+ ifeq ($(DEBUG), yes)
+- CFLAGS += -O0 -g -D_DEBUG
+- CXXFLAGS += -O0 -g -D_DEBUG
++ CFLAGS += -D_DEBUG
++ CXXFLAGS += -D_DEBUG
+ else
+- CFLAGS += -O2 -s -DNDEBUG
+- CXXFLAGS += -O2 -s -DNDEBUG
++ CFLAGS += -DNDEBUG
++ CXXFLAGS += -DNDEBUG
+ endif
+
+ ifeq ($(USE_THREADED_IIN), yes)
+@@ -183,7 +182,6 @@
+ @echo -e "\tLNK $@"
+ @$(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+ ifeq ($(RELEASE), yes)
+- -@upx -q -9 $@ > /dev/null
+ endif
+
+
diff --git a/dev-games/hdl_dump/hdl_dump-0.9.2.20180722.ebuild b/dev-games/hdl_dump/hdl_dump-0.9.2.20180722.ebuild
new file mode 100644
index 000000000000..d35f64fad47b
--- /dev/null
+++ b/dev-games/hdl_dump/hdl_dump-0.9.2.20180722.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+COMMIT="67e66ca0e0a0000563f75c573a046cb8614745ad"
+DESCRIPTION="Game installer for PlayStation 2 HD Loader and Open PS2 Loader"
+HOMEPAGE="https://github.com/AKuHAK/hdl-dump"
+SRC_URI="https://github.com/AKuHAK/hdl-dump/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+S="${WORKDIR}/${PN//_/-}-${COMMIT}"
+
+PATCHES=(
+ "${FILESDIR}"/Makefile.patch
+)
+
+src_prepare() {
+ default
+
+ # Be more verbose. Patching this would be messy.
+ sed -i -r "s/^(\s+)@/\1/" Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ RELEASE=$(usex debug no yes) \
+ IIN_OPTICAL_MMAP=yes
+}
+
+src_install() {
+ dobin hdl_dump
+ dodoc AUTHORS CHANGELOG README.md
+}
diff --git a/dev-games/hdl_dump/metadata.xml b/dev-games/hdl_dump/metadata.xml
index b5988412c8c3..2cb715d74b4f 100644
--- a/dev-games/hdl_dump/metadata.xml
+++ b/dev-games/hdl_dump/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AKuHAK/hdl-dump</remote-id>
+ </upstream>
</pkgmetadata>