summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/libidn2/Manifest1
-rw-r--r--net-dns/libidn2/libidn2-2.3.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-dns/libidn2/Manifest b/net-dns/libidn2/Manifest
index dbd184fb2f67..7319c60bf8b5 100644
--- a/net-dns/libidn2/Manifest
+++ b/net-dns/libidn2/Manifest
@@ -1 +1,2 @@
DIST libidn2-2.3.0.tar.gz 2164993 BLAKE2B 3c103831c39fa3fd0340c9c45f3f683483207ade9cadc8d85b046a698f75bbe5ce6829de69a5cb238404d243b7a39ef44d69ea4ea80c22b813eafbacae615a8b SHA512 a2bf6d2249948bce14fbbc802f8af1c9b427fc9bf64203a2f3d7239d8e6061d0a8e7970a23e8e5889110a654a321e0504c7a6d049bb501e7f6a23d42b50b6187
+DIST libidn2-2.3.1.tar.gz 2188338 BLAKE2B 323840b0d84f41cc746ca9b5a24169a374e95bd4669b96d7b62ac3304f6d78195acef7739628cf7e31cf7b230ffb60f74961c3e22693571fd2fc7cbb35f1ac23 SHA512 4d77a4a79e08a05e46fc14827f987b9e7645ebf5d0c0869eb96f9902c2f6b73ea69fd6f9f97b80a9f07cce84f7aa299834df91485d4e7c16500d31a4b9865fe4
diff --git a/net-dns/libidn2/libidn2-2.3.1.ebuild b/net-dns/libidn2/libidn2-2.3.1.ebuild
new file mode 100644
index 000000000000..85c2e06f7552
--- /dev/null
+++ b/net-dns/libidn2/libidn2-2.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/libidn/libidn2"
+SRC_URI="
+ mirror://gnu/libidn/${P}.tar.gz
+"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/libunistring:=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ sys-apps/help2man
+"
+S=${WORKDIR}/${P/a/}
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # Darwin ar chokes when TMPDIR doesn't exist (as done for some
+ # reason in the Makefile)
+ sed -i -e '/^TMPDIR = /d' Makefile.in || die
+ export TMPDIR="${T}"
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ $(use_enable static-libs static) \
+ --disable-doc \
+ --disable-gcc-warnings \
+ --disable-gtk-doc
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}