summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.24.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.24.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.24.ebuild
index a9a2abcec259..dbdf1906fe82 100644
--- a/app-editors/wxhexeditor/wxhexeditor-0.24.ebuild
+++ b/app-editors/wxhexeditor/wxhexeditor-0.24.ebuild
@@ -30,8 +30,11 @@ PATCHES=(
)
pkg_pretend() {
- tc-has-openmp \
- || die "${PN} uses OpenMP libraries. Please use an OpenMP-capable compiler."
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
src_prepare() {