summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/x265/Manifest1
-rw-r--r--media-libs/x265/files/1.8-build-Disable-march-selection-from-CMakeLists.txt.patch37
-rw-r--r--media-libs/x265/files/1.8-extralibs_order.patch29
-rw-r--r--media-libs/x265/x265-1.8-r3.ebuild176
4 files changed, 0 insertions, 243 deletions
diff --git a/media-libs/x265/Manifest b/media-libs/x265/Manifest
index 24b12f1ef6f4..567ea94712c6 100644
--- a/media-libs/x265/Manifest
+++ b/media-libs/x265/Manifest
@@ -1,3 +1,2 @@
-DIST x265_1.8.tar.gz 918469 SHA256 760e6280c688f1ea90c492d19fc6d4084ca1c4b0ea9b2e3c736d32565c30d857 SHA512 498c25ff6e5c68849db11d1509cc6f7e96d3a2e6594542589ac5b9f6d65a09ab3af590dcc3357f985f218f8d54af364c998cfedfbe95644747835c059214935c WHIRLPOOL ef5c1a31e8ab45c2918e24e97c09809eda735df354d9000e3935b054ca01fd60ef1d1afad6c161c7c62b8b016c2a80155665448a18e4037fab8c56a841488eeb
DIST x265_2.2.tar.gz 1203801 SHA256 b872552535e41fbffa03ba7cbcd3479c42c4053868309292e78e147b7773ac4b SHA512 335bb38cf0892f2c4310033b076d51115c0b7faa9596a4f556dde5e3d1378d04f3d0055cb0bf2441eb725b7f84c246174bdc315eeb4ddde61ef9d79469f44eef WHIRLPOOL 6aa6fb3669abbb6e3fd9dd9ffe38f595805a61beedcfccd509606a9c3a19f79037a518269206ddcac7231de45165f000e59c3b0f279921a6aa8de2cb5b38a7ec
DIST x265_2.3.tar.gz 1215719 SHA256 47520ac3424790168ea5c2db4a3cf12ca4d55a1790720007916652f07af3e41f SHA512 c863e4bd95323baf5c1ee388c2d9e460749940b947a795e0bce7bffab620258fb7aafbbf2956225491f4532f715392df3d40f19301964e00c3ac2971cd7d8809 WHIRLPOOL c7fa65f74b342ae32ae7b89aed86e6270607ec22479c95b62bd6b3e2cb958635d459e3770fe73e7599e572b01b171d101f5fb50c161139c867bea1ddda217c10
diff --git a/media-libs/x265/files/1.8-build-Disable-march-selection-from-CMakeLists.txt.patch b/media-libs/x265/files/1.8-build-Disable-march-selection-from-CMakeLists.txt.patch
deleted file mode 100644
index a2e8f0d0477b..000000000000
--- a/media-libs/x265/files/1.8-build-Disable-march-selection-from-CMakeLists.txt.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://bitbucket.org/multicoreware/x265/pull-requests/21
-
-From e89069148db716d30fb81c798d0cfd83250a9f5a Mon Sep 17 00:00:00 2001
-From: Bertrand Jacquin <bertrand@jacquin.bzh>
-Date: Sat, 10 Oct 2015 00:05:41 +0100
-Subject: [PATCH] build: Disable -march selection from CMakeLists.txt
-
-x32 arch as defined on https://sites.google.com/site/x32abi is neither
-X86 nor X64, then forcing -march=i686 leads to build failure as wrong
--march is used.
-
-Forcing -march, -mfloat-abi and -mfpu for ARM is also wrong
-
-As a global sanity sake, disable all forced -march in CMakeLists
----
- source/CMakeLists.txt | 7 -------
- 1 file changed, 7 deletions(-)
-
-diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
-index 764d5f2..fbc0d49 100644
---- a/source/CMakeLists.txt
-+++ b/source/CMakeLists.txt
-@@ -167,14 +167,7 @@ if(GCC)
- if(NATIVE_BUILD)
- if(INTEL_CXX)
- add_definitions(-xhost)
-- else()
-- add_definitions(-march=native)
- endif()
-- elseif(X86 AND NOT X64)
-- add_definitions(-march=i686)
-- endif()
-- if(ARM)
-- add_definitions(-march=armv6 -mfloat-abi=hard -mfpu=vfp)
- endif()
- if(FPROFILE_GENERATE)
- if(INTEL_CXX)
diff --git a/media-libs/x265/files/1.8-extralibs_order.patch b/media-libs/x265/files/1.8-extralibs_order.patch
deleted file mode 100644
index e30c0f96573c..000000000000
--- a/media-libs/x265/files/1.8-extralibs_order.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://bitbucket.org/multicoreware/x265/pull-requests/22
-
-Link EXTRA_LIB before PLATFORM_LIBS since they're static libraries and as-needed
-might drop required libraries if they come after.
-
-Index: x265_11047/source/CMakeLists.txt
-===================================================================
---- x265_11047.orig/source/CMakeLists.txt
-+++ x265_11047/source/CMakeLists.txt
-@@ -455,6 +455,9 @@ option(ENABLE_SHARED "Build shared libra
- if(ENABLE_SHARED)
- add_library(x265-shared SHARED "${PROJECT_BINARY_DIR}/x265.def" ${YASM_OBJS}
- ${X265_RC_FILE} $<TARGET_OBJECTS:encoder> $<TARGET_OBJECTS:common>)
-+ if(EXTRA_LIB)
-+ target_link_libraries(x265-shared ${EXTRA_LIB})
-+ endif()
- target_link_libraries(x265-shared ${PLATFORM_LIBS})
- if(MSVC)
- set_target_properties(x265-shared PROPERTIES OUTPUT_NAME libx265)
-@@ -480,9 +483,6 @@ if(ENABLE_SHARED)
- ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
- RUNTIME DESTINATION ${BIN_INSTALL_DIR})
- endif()
-- if(EXTRA_LIB)
-- target_link_libraries(x265-shared ${EXTRA_LIB})
-- endif()
- if(LINKER_OPTIONS)
- # set_target_properties can't do list expansion
- string(REPLACE ";" " " LINKER_OPTION_STR "${LINKER_OPTIONS}")
diff --git a/media-libs/x265/x265-1.8-r3.ebuild b/media-libs/x265/x265-1.8-r3.ebuild
deleted file mode 100644
index f855da168803..000000000000
--- a/media-libs/x265/x265-1.8-r3.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit cmake-utils multilib-minimal multilib multibuild flag-o-matic
-
-if [[ ${PV} = 9999* ]]; then
- inherit mercurial
- EHG_REPO_URI="https://bitbucket.org/multicoreware/x265"
-else
- SRC_URI="
- https://bitbucket.org/multicoreware/x265/downloads/${PN}_${PV}.tar.gz
- http://ftp.videolan.org/pub/videolan/x265/${PN}_${PV}.tar.gz"
- KEYWORDS="amd64 arm hppa ppc ppc64 x86"
-fi
-
-DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"
-HOMEPAGE="http://x265.org/"
-
-LICENSE="GPL-2"
-# subslot = libx265 soname
-SLOT="0/68"
-IUSE="+10bit 12bit numa pic test"
-
-ASM_DEPEND=">=dev-lang/yasm-1.2.0"
-RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- abi_x86_32? ( ${ASM_DEPEND} )
- abi_x86_64? ( ${ASM_DEPEND} )"
-
-src_unpack() {
- if [[ ${PV} = 9999* ]]; then
- mercurial_src_unpack
- # Can't set it at global scope due to mercurial.eclass limitations...
- export S=${WORKDIR}/${P}/source
- else
- unpack ${A}
- export S="$(echo "${WORKDIR}/${PN}_"*"/source")"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PV}-build-Disable-march-selection-from-CMakeLists.txt.patch" # bug #510890
- epatch "${FILESDIR}/1.8-extralibs_order.patch"
-}
-
-# By default, the library and the encoder is configured for only one output bit
-# depth. Meaning, one has to rebuild libx265 if (s)he wants to produce HEVC
-# files with a different bit depth, which is annoying. However, upstream
-# supports proper namespacing for 8bits, 10bits & 12bits HEVC and linking all
-# that together so that the resulting library can produce all three of them
-# instead of only one.
-# The API requires the bit depth parameter, so that libx265 can then chose which
-# variant of the encoder to use.
-# To achieve this, we have to build one (static) library for each non-main
-# variant, and link it into the main library.
-# Upstream documents using the 8bit variant as main library, hence we do not
-# allow disabling it: "main" *MUST* come last in the following list.
-
-x265_get_variants() {
- local variants=""
- use 12bit && variants+="main12 "
- use 10bit && variants+="main10 "
- variants+="main"
- echo "${variants}"
-}
-
-x265_variant_src_configure() {
- mkdir -p "${BUILD_DIR}" || die
- pushd "${BUILD_DIR}" >/dev/null || die
-
- local mycmakeargs=( "${myabicmakeargs[@]}" )
- case "${MULTIBUILD_VARIANT}" in
- "main12")
- mycmakeargs+=(
- -DHIGH_BIT_DEPTH=ON
- -DEXPORT_C_API=OFF
- -DENABLE_SHARED=OFF
- -DENABLE_CLI=OFF
- -DMAIN12=ON
- )
- if [[ ${ABI} = x86 ]] ; then
- mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
- fi
- ;;
- "main10")
- mycmakeargs+=(
- -DHIGH_BIT_DEPTH=ON
- -DEXPORT_C_API=OFF
- -DENABLE_SHARED=OFF
- -DENABLE_CLI=OFF
- )
- if [[ ${ABI} = x86 ]] ; then
- mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
- fi
- ;;
- "main")
- if (( "${#MULTIBUILD_VARIANTS[@]}" > 1 )) ; then
- local myvariants=( "${MULTIBUILD_VARIANTS[@]}" )
- unset myvariants[${#MULTIBUILD_VARIANTS[@]}-1]
- local liblist=""
- for v in "${myvariants[@]}" ; do
- ln -s "${BUILD_DIR%-*}-${v}/libx265.a" "libx265_${v}.a" || die
- liblist+="libx265_${v}.a;"
- done
- mycmakeargs+=(
- -DEXTRA_LIB="${liblist}"
- -DEXTRA_LINK_FLAGS=-L.
- -DLINKED_10BIT=$(usex 10bit)
- -DLINKED_12BIT=$(usex 12bit)
- )
- fi
- ;;
- *)
- die "Unknown variant: ${MULTIBUILD_VARIANT}";;
- esac
- cmake-utils_src_configure
- popd >/dev/null || die
-}
-
-multilib_src_configure() {
- append-cflags -fPIC
- append-cxxflags -fPIC
- local myabicmakeargs=(
- $(cmake-utils_use_enable test TESTS)
- $(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
- -DCMAKE_DISABLE_FIND_PACKAGE_Numa=$(usex numa OFF ON)
- -DLIB_INSTALL_DIR="$(get_libdir)"
- )
-
- if [[ ${ABI} = x86 ]] ; then
- # Bug #528202
- if use pic ; then
- ewarn "PIC has been requested but x86 asm is not PIC-safe, disabling it."
- myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
- fi
- elif [[ ${ABI} = x32 ]] ; then
- # bug #510890
- myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
- fi
-
- local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
- multibuild_foreach_variant x265_variant_src_configure
-}
-
-multilib_src_compile() {
- local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
- multibuild_foreach_variant cmake-utils_src_compile
-}
-
-x265_variant_src_test() {
- if [ -x "${BUILD_DIR}/test/TestBench" ] ; then
- "${BUILD_DIR}/test/TestBench" || die
- else
- einfo "Unit tests check only assembly."
- einfo "You do not seem to have any for ABI=${ABI}, x265 variant=${MULTIBUILD_VARIANT}"
- einfo "Skipping tests."
- fi
-}
-
-multilib_src_test() {
- local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
- multibuild_foreach_variant x265_variant_src_test
-}
-
-multilib_src_install() {
- # Install only "main" variant since the others are already linked into it.
- local MULTIBUILD_VARIANTS=( "main" )
- multibuild_foreach_variant cmake-utils_src_install
-}
-
-multilib_src_install_all() {
- dodoc -r "${S}/../doc/"*
-}