summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/freeciv/files/freeciv-2.6.2-qt515.patch39
-rw-r--r--games-strategy/freeciv/freeciv-2.6.2.ebuild4
2 files changed, 43 insertions, 0 deletions
diff --git a/games-strategy/freeciv/files/freeciv-2.6.2-qt515.patch b/games-strategy/freeciv/files/freeciv-2.6.2-qt515.patch
new file mode 100644
index 000000000000..db5e657a5850
--- /dev/null
+++ b/games-strategy/freeciv/files/freeciv-2.6.2-qt515.patch
@@ -0,0 +1,39 @@
+From 87f4abf81d530b825d0af772d95fd1ea78503e64 Mon Sep 17 00:00:00 2001
+From: Marko Lindqvist <cazfi74@gmail.com>
+Date: Tue, 7 Apr 2020 13:22:14 +0300
+Subject: [PATCH] Include <QPainterPath> where needed
+
+This fixes Qt-client build on OpenEmbedded
+
+See hrm Bug #868060
+
+Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
+---
+ client/gui-qt/canvas.cpp | 1 +
+ client/gui-qt/dialogs.cpp | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/client/gui-qt/canvas.cpp b/client/gui-qt/canvas.cpp
+index 24291bc183..00fa1b8f52 100644
+--- a/client/gui-qt/canvas.cpp
++++ b/client/gui-qt/canvas.cpp
+@@ -18,6 +18,7 @@
+ // Qt
+ #include <QFontMetrics>
+ #include <QPainter>
++#include <QPainterPath>
+
+ // qt-client
+ #include "canvas.h"
+diff --git a/client/gui-qt/dialogs.cpp b/client/gui-qt/dialogs.cpp
+index e0f9de31d4..4b3254c496 100644
+--- a/client/gui-qt/dialogs.cpp
++++ b/client/gui-qt/dialogs.cpp
+@@ -24,6 +24,7 @@
+ #include <QMessageBox>
+ #include <QMouseEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QRadioButton>
+ #include <QRect>
+ #include <QSignalMapper>
diff --git a/games-strategy/freeciv/freeciv-2.6.2.ebuild b/games-strategy/freeciv/freeciv-2.6.2.ebuild
index e81667668342..2b5d791692c3 100644
--- a/games-strategy/freeciv/freeciv-2.6.2.ebuild
+++ b/games-strategy/freeciv/freeciv-2.6.2.ebuild
@@ -70,6 +70,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}/${P}-qt515.patch" #728254
+)
+
pkg_setup() {
if use !dedicated && use !server ; then
ewarn "Disabling server USE flag will make it impossible"