summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/package.mask1
-rw-r--r--x11-wm/notion/notion-3_p2015061300-r100.ebuild101
-rw-r--r--x11-wm/notion/notion-9999.ebuild43
3 files changed, 128 insertions, 17 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 60a835a2c5da..73a18f18d464 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -608,6 +608,7 @@ kde-apps/kdebase-meta:5
>=www-servers/lighttpd-1.4.55-r100
>=x11-misc/devilspie2-0.43-r100
>=x11-wm/awesome-4.3-r100
+>=x11-wm/notion-3_p2015061300-r100
>=mail-filter/opendkim-2.10.3-r25
# Azamat H. Hackimov <azamat.hackimov@gmail.com> (2020-10-06)
diff --git a/x11-wm/notion/notion-3_p2015061300-r100.ebuild b/x11-wm/notion/notion-3_p2015061300-r100.ebuild
new file mode 100644
index 000000000000..2aee50148789
--- /dev/null
+++ b/x11-wm/notion/notion-3_p2015061300-r100.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..2} )
+
+inherit lua-single toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
+HOMEPAGE="https://notionwm.net/"
+SRC_URI="https://github.com/raboof/${PN}/archive/${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls xinerama +xrandr"
+
+RDEPEND="${LUA_DEPS}
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}"
+# luac is called at build time
+BDEPEND="${LUA_DEPS}
+ virtual/pkgconfig"
+
+# mod_xrandr references mod_xinerama
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ xrandr? ( xinerama )"
+
+# needs slingshot,... not in tree
+RESTRICT=test
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3_p2015061300-pkg-config.patch
+)
+
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ default
+
+ sed -e "/^CFLAGS/{s: =: +=: ; s:-Os:: ; s:-g::}" \
+ -e "/^LDFLAGS/{s: =: +=: ; s:-Wl,--as-needed::}" \
+ -i system-autodetect.mk || die
+ echo > build/lua-detect.mk
+}
+
+src_configure() {
+ { echo "CFLAGS += -D_DEFAULT_SOURCE"
+ echo "PREFIX=${EROOT}/usr"
+ echo "DOCDIR=\$(PREFIX)/share/doc/${PF}"
+ echo "ETCDIR=${EROOT}/etc/${PN}"
+ echo "LIBDIR=\$(PREFIX)/$(get_libdir)"
+ echo "VARDIR=${EROOT}/var/cache/${PN}"
+ echo "X11_PREFIX=${EROOT}/usr"
+ echo "STRIPPROG=true"
+ echo "CC=$(tc-getCC)"
+ echo "AR=$(tc-getAR)"
+ echo "RANLIB=$(tc-getRANLIB)"
+ echo "LUA_MANUAL=1"
+ echo "LUA=${LUA}"
+ echo "LUAC=/usr/bin/luac5.1"
+ echo "LUA_LIBS=$(lua_get_LIBS)"
+ echo "LUA_INCLUDES=$(lua_get_CFLAGS)"
+ use nls || echo "DEFINES+=-DCF_NO_LOCALE -DCF_NO_GETTEXT"
+ } > system-local.mk
+
+ if ! use xinerama ; then
+ sed -e 's/mod_xinerama//g' -i modulelist.mk || die
+ fi
+
+ if ! use xrandr ; then
+ sed -e 's/mod_xrandr//g' -i modulelist.mk || die
+ sed -e '/mod_xrandr/d' \
+ -i etc/cfg_defaults.lua || die
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/notion
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/notion.desktop
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+DOC_CONTENTS="If you want notion to have an ability to view a file based on its
+guessed MIME type you should emerge app-misc/run-mailcap."
diff --git a/x11-wm/notion/notion-9999.ebuild b/x11-wm/notion/notion-9999.ebuild
index 575a0c3ed279..56c03dbb134d 100644
--- a/x11-wm/notion/notion-9999.ebuild
+++ b/x11-wm/notion/notion-9999.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils git-r3 multilib toolchain-funcs readme.gentoo
+LUA_COMPAT=( lua5-{1..2} )
+
+inherit git-r3 lua-single toolchain-funcs readme.gentoo-r1
DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
HOMEPAGE="https://notionwm.net/"
@@ -14,24 +16,27 @@ SLOT="0"
KEYWORDS=""
IUSE="nls xinerama +xrandr"
-RDEPEND=">=dev-lang/lua-5.1:0=
+RDEPEND="${LUA_DEPS}
x11-libs/libSM
x11-libs/libX11
x11-libs/libXext
nls? ( sys-devel/gettext )
xinerama? ( x11-libs/libXinerama )
xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+# luac is called at build time
+BDEPEND="${LUA_DEPS}
+ virtual/pkgconfig"
# mod_xrandr references mod_xinerama
-REQUIRED_USE="xrandr? ( xinerama )"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ xrandr? ( xinerama )"
-# needs luaposix,slingshot,... not in tree
+# needs slingshot,... not in tree
RESTRICT=test
src_prepare() {
- epatch "${FILESDIR}/${PN}-3_p2015061300-pkg-config.patch"
+ default
sed -e "/^CFLAGS/{s: =: +=: ; s:-Os:: ; s:-g::}" \
-e "/^LDFLAGS/{s: =: +=: ; s:-Wl,--as-needed::}" \
@@ -41,21 +46,21 @@ src_prepare() {
src_configure() {
{ echo "CFLAGS += -D_DEFAULT_SOURCE"
- echo "PREFIX=${ROOT}usr"
+ echo "PREFIX=${EROOT}/usr"
echo "DOCDIR=\$(PREFIX)/share/doc/${PF}"
- echo "ETCDIR=${ROOT}etc/${PN}"
+ echo "ETCDIR=${EROOT}/etc/${PN}"
echo "LIBDIR=\$(PREFIX)/$(get_libdir)"
- echo "VARDIR=${ROOT}var/cache/${PN}"
- echo "X11_PREFIX=${ROOT}usr"
+ echo "VARDIR=${EROOT}/var/cache/${PN}"
+ echo "X11_PREFIX=${EROOT}/usr"
echo "STRIPPROG=true"
echo "CC=$(tc-getCC)"
echo "AR=$(tc-getAR)"
echo "RANLIB=$(tc-getRANLIB)"
echo "LUA_MANUAL=1"
- echo "LUA=\$(BINDIR)/lua"
- echo "LUAC=\$(BINDIR)/luac"
- echo "LUA_LIBS=\$(shell pkg-config --libs lua)"
- echo "LUA_INCLUDES=\$(shell pkg-config --cflags)"
+ echo "LUA=${LUA}"
+ echo "LUAC=luac"
+ echo "LUA_LIBS=$(lua_get_LIBS)"
+ echo "LUA_INCLUDES=$(lua_get_CFLAGS)"
use nls || echo "DEFINES+=-DCF_NO_LOCALE -DCF_NO_GETTEXT"
} > system-local.mk
@@ -79,7 +84,11 @@ src_install() {
insinto /usr/share/xsessions
doins "${FILESDIR}"/notion.desktop
- readme.gentoo_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
}
DOC_CONTENTS="If you want notion to have an ability to view a file based on its