summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/albert/Manifest2
-rw-r--r--x11-misc/albert/albert-0.13.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/albert/Manifest b/x11-misc/albert/Manifest
index 5cfc8f321994..2e5fd2840bc0 100644
--- a/x11-misc/albert/Manifest
+++ b/x11-misc/albert/Manifest
@@ -1 +1,3 @@
DIST albert-0.12.0.tar.gz 404748 SHA256 e1ec7783b6cc22e5ed28d2f1ac6148528cb3eb734f139945b49d44e07770d9c8 SHA512 56d141a2c6b98744c0b34a7adbbca8b6af93545a7b067263acf59fc63d99ec7d9f19f2f3c73f477e5f35448ae8a563c9f132bed87be135467f8f0c1462f9b031 WHIRLPOOL 328fe6efdcce988e37bf30448ea147d0aac5a69aaee267e3453c4b0abd621a58f8b29f11727ecaf199129d9d11bc03b2fea71651c17aaf22f06e51ba582beaaa
+DIST albert-0.13.0-plugins.tar.gz 462749 SHA256 23ce66637609ca035809f2461f0d56c31347504e5562f0290703be4639e5f4ca SHA512 1ac4ddc3360d95a4cd60200ad4b67a8959a5d05304c3851c4cd9a194acb896f56ebe59e50373d6c2733fe10642a517d4262a85f6a1436524d917abf9c47dfd52 WHIRLPOOL 171d198f113b96d0389742b1e723909f6069b6f4b252f71534ecfdb7f3f45a3f1fe061abc483e8cc3ec466e173218bba70f47cabc6f4f9e7a0f9b4dcc8f8c71e
+DIST albert-0.13.0.tar.gz 80758 SHA256 d0897be526696232345174a80e770859df1c7ff42ea007c12492a9d3360627a3 SHA512 297f54bc3506a8143ed522be1044e2212e724fbc9309822860c409b3260ba8735fbb2569e539a3a57640f7c2165b09c306d8e48b5180dd74f8b7442723f6695c WHIRLPOOL ae5dc3bc929fdaebe959812c6c145266988b6f758cb5d4e657d75dd8a4613dbd106410a43e1172bdd79ed821f8204985bfbd3830dc5469770118bd1a1d0871f4
diff --git a/x11-misc/albert/albert-0.13.0.ebuild b/x11-misc/albert/albert-0.13.0.ebuild
new file mode 100644
index 000000000000..f1eab3bcefd0
--- /dev/null
+++ b/x11-misc/albert/albert-0.13.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLUGINS_HASH="bcca6aad60aa784cf61b8730e7865b399f163cc2"
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Desktop agnostic launcher"
+HOMEPAGE="https://albertlauncher.github.io/"
+# plugins is a git submodule. the hash is taken from the submodule reference in the ${PV} tag.
+SRC_URI="https://github.com/albertlauncher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/albertlauncher/plugins/archive/${PLUGINS_HASH}.tar.gz -> ${P}-plugins.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-cpp/muParser
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ mv "${WORKDIR}"/plugins-${PLUGINS_HASH}/* "${S}"/plugins/ || die
+
+ sed -e "s/DESTINATION lib/DESTINATION $(get_libdir)/" \
+ -i plugins/*/CMakeLists.txt \
+ -i src/lib/*/CMakeLists.txt || die
+
+ # plugin needs virtualbox installed to build, untested
+ sed -i -e "/add_subdirectory(virtualbox)/s/^/#/" plugins/CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DEBUG_EXTENSIONS=$(usex debug)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}