summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/clion/Manifest1
-rw-r--r--dev-util/clion/clion-2017.3.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index d8e28ba4250f..470a3769d162 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1,3 +1,4 @@
DIST clion-143.1186.tar.gz 220702330 BLAKE2B 05799e66aff500adbb66f553f6fc00c58d1ea5e352b0f3d2e50897fbaa48c0977438027ec6282133502c0ce29d2392c49b2c000eae35407d8c3947b7e2d5ebe7 SHA512 d4ea1bad5f3da3bab569380114011798c29e633009867c8020363c9af72326ebaa3232dff9c931a67dd0a0195bf4903647e250963c7aeebe9ad83340c988cbad
DIST clion-2016.2.1.tar.gz 287103613 BLAKE2B a3b31d5a5de5a9640cc7298ee6431030ed3e5954455a34845ee525b0edd73a265d0ac38df50094564f68f9f7c17883571c61c2e5dadcdfe504f7320492d7380c SHA512 a4734c1b5d544cb7f6bd4752f5853d3c44e123e8ad8584b76098ef51a00261350d49bdd628d08c171f7c04b77862e8f28b5d8f16813c282542f83a16100c7415
+DIST clion-2017.3.1.tar.gz 331052532 BLAKE2B 0cb3d983b17a36592ce56cada1643039302298e302f5d165d9d3b18fe412101326b02ec87e7b6b3050267cabd67771c86b98bda1c923c91fd2175af4e6ea69f5 SHA512 ef8526586f11eade4fe1b9c466206d727b98177fbee04378bd38bc1a050a6942d3ccdda11179891c57e188f884c3f639d74703b79e618fb9fac85bdacd43aa42
DIST clion-2017.3.tar.gz 331019046 BLAKE2B 0b9fb1a83de6f0df365997f1582536ea7bba050aa9c922c1023a989ec47e2978f7ea451a447dfad56edc65d417cbbdbd6398e6ea7065c84012a4bcf5b9e1e9e8 SHA512 4535534c708b7b6ae8c1cd17b47ae23bc3da02f80b01bed1143ccc7a62773aca2d4464472f1f2a62dc410cb5711616f0097bbf7fc44a929dfa2e7c22f1081b2a
diff --git a/dev-util/clion/clion-2017.3.1.ebuild b/dev-util/clion/clion-2017.3.1.ebuild
new file mode 100644
index 000000000000..e648402ebdbb
--- /dev/null
+++ b/dev-util/clion/clion-2017.3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop
+inherit eutils
+
+SLOT="0"
+
+SRC_URI="http://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A complete toolset for C and C++ development"
+HOMEPAGE="http://www.jetbrains.com/clion"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+
+# RDEPENDS may cause false positives in repoman.
+# clion requires cmake and gdb at runtime to build and debug C/C++ projects
+RDEPEND="
+ sys-devel/gdb
+ dev-util/cmake"
+
+QA_PREBUILT="opt/${P}/*"
+
+src_prepare() {
+ default
+
+ local remove_me=(
+ bin/gdb/bin
+ bin/gdb/lib
+ bin/gdb/share
+ bin/cmake
+ license/CMake*
+ plugins/tfsIntegration/lib/native/hpux
+ plugins/tfsIntegration/lib/native/solaris
+ )
+
+ use amd64 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86_64 )
+ use arm || remove_me+=( bin/fsnotifier-arm plugins/tfsIntegration/lib/native/linux/arm )
+ use ppc || remove_me+=( plugins/tfsIntegration/lib/native/linux/ppc )
+ use x86 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86 )
+
+ rm -rv "${remove_me[@]}" || die
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{clion.sh,fsnotifier{,64}}
+
+ make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+ newicon "bin/${PN}.svg" "${PN}.svg"
+ make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+}