summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-go/go-tools/Manifest1
-rw-r--r--dev-go/go-tools/go-tools-0_pre20160220.ebuild105
2 files changed, 0 insertions, 106 deletions
diff --git a/dev-go/go-tools/Manifest b/dev-go/go-tools/Manifest
index 974d3f9e21b7..60ad5f1d04d2 100644
--- a/dev-go/go-tools/Manifest
+++ b/dev-go/go-tools/Manifest
@@ -1,4 +1,3 @@
DIST github.com-golang-net-aaf60122140d3fcf75376d319f0554393160eb50.tar.gz 965206 BLAKE2B 018ab877bfa7208bb0ca9b4ede85077ed37c8ee3c7065569646e6c9704715d6810b0286276ea0fa9a271f12ffbe964b41f55ec762711c8a43ccea564607f3265 SHA512 d56f5608e64e8d883a782f0c460f08da20e7d01a97330fad35c8757420ac82fb84b657c3f64e3c4d90a08cc4d8905ab37225d6fab8472e8f1fd3d7be212df8b9
DIST go-favicon.ico 5686 BLAKE2B 331d7684a569fc40fcd147eb812661f42b0ee3ca4c017515c33523b588b012763ce29f24bfce5bc7274e7560ff7dd8e872af43d2b51dc0722ac416b43c11f841 SHA512 0a6fe8bddbce99ed7fd035a3dc998dc9e893060854eee9d1c70bcc8de77b71fd3bd203b2de0f1c9a146f7d47555ab856389e16a372ee41f4ab57be611877fc16
-DIST go-tools-0_pre20160220.tar.gz 1827046 BLAKE2B 26b4080540958764c42fffc1cb6a1597705c0a7ea85357b5169f9a0bf6939d7c5475681f6fede8b46a88ef58c72afa9eaa9da3fb66a3bbbb19942d0a1887bbeb SHA512 95c9deb9b01b2f294818fcc847e457ab313d5831a839bf9cfeb1a00a0efd833de3fdfd3ecfe7ecfa2dd236ffcf963e73205d7b5b25fa41ab51c7601dc632bce1
DIST go-tools-0_pre20180817.tar.gz 2321169 BLAKE2B d1ba93b36b62bfbf53770cab6c96019d1a96db0ff6521f591577d866f74a1f65ec24e41a06f81d0040be7122f2e0da734e68d0a72591040265b5f95b324645fe SHA512 1af6c4a58f4d1985dc55e4342d9a4f26ada646ffe87fafdb5bdf876ad972a9f826da257ff9a10956c24dbc90ed9d6935bb78b4f7d30f9e50493c60f7ce92edb1
diff --git a/dev-go/go-tools/go-tools-0_pre20160220.ebuild b/dev-go/go-tools/go-tools-0_pre20160220.ebuild
deleted file mode 100644
index da04f9371b08..000000000000
--- a/dev-go/go-tools/go-tools-0_pre20160220.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-EGO_PN="golang.org/x/tools/..."
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- EGIT_COMMIT="ee8cb08bfe4453a27a4bd7c86a917800d339c5ac"
- ARCHIVE_URI="https://github.com/golang/tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go Tools"
-HOMEPAGE="https://godoc.org/golang.org/x/tools"
-SRC_URI="${ARCHIVE_URI}
- http://golang.org/favicon.ico -> go-favicon.ico"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND="dev-go/go-net:=
- >=dev-lang/go-1.5"
-RDEPEND="!<dev-lang/go-1.5"
-
-src_prepare() {
- local go_src="${EGO_PN%/...}"
- # disable broken tests
- rm src/${go_src}/cmd/bundle/main_test.go || die
- sed -e 's:TestWeb(:_\0:' \
- -e 's:TestWebIndex(:_\0:' \
- -i src/${go_src}/cmd/godoc/godoc_test.go || die
- sed -e 's:TestVet(:_\0:' \
- -e 's:TestDivergentPackagesExamples(:_\0:' \
- -e 's:TestIncompleteExamples(:_\0:' \
- -i src/${go_src}/cmd/vet/vet_test.go || die
- sed -e 's:TestImportStdLib(:_\0:' \
- -i src/${go_src}/go/gcimporter15/gcimporter_test.go || die
- sed -e 's:TestImportStdLib(:_\0:' \
- -i src/${go_src}/go/importer/import_test.go || die
- sed -e 's:TestStdlib(:_\0:' \
- -i src/${go_src}/go/loader/stdlib_test.go || die
- sed -e 's:TestStdlib(:_\0:' \
- -i src/${go_src}/go/ssa/stdlib_test.go || die
- sed -e 's:TestGorootTest(:_\0:' \
- -e 's:TestTestmainPackage(:_\0:' \
- -i src/${go_src}/go/ssa/interp/interp_test.go || die
- sed -e 's:TestBar(:_\0:' \
- -e 's:TestFoo(:_\0:' \
- -i src/${go_src}/go/ssa/interp/testdata/a_test.go || die
- sed -e 's:TestStdlib(:_\0:' \
- -e 's:TestStdFixed(:_\0:' \
- -e 's:TestStdKen(:_\0:' \
- -i src/${go_src}/go/types/stdlib_test.go || die
- sed -e 's:TestFindImportVendor(:_\0:' \
- -e 's:TestProcessVendor(:_\0:' \
- -i src/${go_src}/imports/fix_test.go || die
-
- # Add favicon to the godoc web interface (bug 551030)
- cp "${DISTDIR}"/go-favicon.ico "src/${go_src}/godoc/static/favicon.ico" ||
- die
- sed -e 's:"example.html",:\0\n\t"favicon.ico",:' \
- -i src/${go_src}/godoc/static/makestatic.go || die
- sed -e 's:<link type="text/css":<link rel="icon" type="image/png" href="/lib/godoc/favicon.ico">\n\0:' \
- -i src/${go_src}/godoc/static/godoc.html || die
-}
-
-src_compile() {
- # Generate static.go with favicon included
- pushd src/golang.org/x/tools/godoc/static >/dev/null || die
- go run makestatic.go || die
- popd >/dev/null
-
- golang-build_src_compile
-}
-
-src_test() {
- # Create a writable GOROOT in order to avoid sandbox violations.
- cp -sR "$(go env GOROOT)" "${T}/goroot" || die
- mkdir -p "${T}/goroot/test" || die
- GOROOT="${T}/goroot" golang-build_src_test
- rm -rf "${T}/goroot"
-}
-
-src_install() {
- # Create a writable GOROOT in order to avoid sandbox violations.
- cp -sR "$(go env GOROOT)" "${T}/goroot" || die
- cp -sR "$(get_golibdir_gopath)" "${T}/gopath" || die
-
- GOROOT="${T}/goroot" GOPATH="${WORKDIR}/${P}:${T}/gopath" go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
- golang_install_pkgs
-
- # bug 558818: install binaries in $GOROOT/bin to avoid file collisions
- exeinto "$(go env GOROOT)/bin"
- doexe bin/*
- # godoc location varies depending on whether or not it's
- # installed on the system (bug 591656)
- [[ -e bin/godoc ]] || doexe "${T}/goroot/bin/godoc"
- dodir /usr/bin
- ln "${ED}$(go env GOROOT)/bin/godoc" "${ED}usr/bin/godoc" || die
-
- rm "${D}"$(go env GOROOT)/bin/{cover,vet} || die
-}