summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/swell-foop/Manifest1
-rw-r--r--games-puzzle/swell-foop/swell-foop-3.34.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/games-puzzle/swell-foop/Manifest b/games-puzzle/swell-foop/Manifest
index ca3d020e6758..8b4ebbd1c0d3 100644
--- a/games-puzzle/swell-foop/Manifest
+++ b/games-puzzle/swell-foop/Manifest
@@ -1 +1,2 @@
DIST swell-foop-3.30.0.tar.xz 1117832 BLAKE2B 4cbf829140bd3ff14c09c83b8ebf8a82a00e97d8f73f82ad3fe11220d9ef89a1bdd116ec28235e5ae02bf258021ff6fceb968f1e39598ea606a4c613e0a43f8f SHA512 233ffd2acec9590e97d410a4084e2fa6f9e1b9dc80aec643c8a20de008410930a3cbda901dee63180c6ea469c91db489d513d9bc34edc4e3448cc53a3c76e029
+DIST swell-foop-3.34.1.tar.xz 732008 BLAKE2B e41527ce485fc7d41b3b8667fba1100fc79a1683adbe7948ecb0f73b418f5e8bcd8c5eeb15c1083cfcbb0237294016ea49510ae6103e2cfc6bc93b508a61a02f SHA512 53625882a755959349f259f5527a48f926e6b8e0493eb81ac257fed6869b87d48e789e4a2141bee7aa8910fb061ca9d7541ceef7f3bdb7a5138068cc6dd16b81
diff --git a/games-puzzle/swell-foop/swell-foop-3.34.1.ebuild b/games-puzzle/swell-foop/swell-foop-3.34.1.ebuild
new file mode 100644
index 000000000000..ca8ce00c843f
--- /dev/null
+++ b/games-puzzle/swell-foop/swell-foop-3.34.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=x11-libs/gtk+-3.12:3
+ >=media-libs/clutter-1.14.0:1.0
+ >=media-libs/clutter-gtk-1.5.0:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}