summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/mtpfs/Manifest1
-rw-r--r--sys-fs/mtpfs/mtpfs-1.0.ebuild45
-rw-r--r--sys-fs/mtpfs/mtpfs-1.1-r3.ebuild56
3 files changed, 0 insertions, 102 deletions
diff --git a/sys-fs/mtpfs/Manifest b/sys-fs/mtpfs/Manifest
index 273547b72b57..a6f34e7605c0 100644
--- a/sys-fs/mtpfs/Manifest
+++ b/sys-fs/mtpfs/Manifest
@@ -1,2 +1 @@
-DIST mtpfs-1.0.tar.gz 104242 BLAKE2B b29e0cd88a726affbe0810ceac38378c60b97de99eaf0ca4f5b249f87ca982cc7c83faa0bbfc87b4ffb351c10573ce4778de1f9911842707279c4fb08b157d33 SHA512 af3bd067410f51bf76619a5d98a23c2a5755d2f5e2764221af145a463ab1b819332b00e358887488f2e26e29c91dcabceedf5f8637d97a9b2ba06b91281a6a4d
DIST mtpfs-1.1.tar.gz 108329 BLAKE2B 7172c1ca0b31a532d0ba1068874c0fd4012dd80da4684d69fa36355126be0c56d79570d5fe5f42876d1a98f49bbc21b0f446c08e28b62e20583bbfd4d7054f62 SHA512 627f1a5efa024276f58857e0cb2a2b3057ab9ba6c26d8dcba9de066f4c0efc56a5c991e000e67763b874ee9feb1d9a1e176872b56dd13b146823e8724f2052c8
diff --git a/sys-fs/mtpfs/mtpfs-1.0.ebuild b/sys-fs/mtpfs/mtpfs-1.0.ebuild
deleted file mode 100644
index 0968c88c8653..000000000000
--- a/sys-fs/mtpfs/mtpfs-1.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-DESCRIPTION="A FUSE filesystem providing access to MTP devices"
-HOMEPAGE="https://www.adebenham.com/mtpfs/"
-SRC_URI="https://www.adebenham.com/debian/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug"
-
-DEPEND="dev-libs/glib:2
- media-libs/libid3tag
- media-libs/libmad
- media-libs/libmtp
- sys-fs/fuse"
-RDEPEND="${DEPEND}"
-
-DOCS=(AUTHORS NEWS README)
-
-src_prepare() {
- sed -e "/#include <string.h>/ a\
- #include <stdlib.h>" -i mtpfs.h id3read.c || die #implicit
-}
-
-src_configure() {
- econf $(use_enable debug)
-}
-
-pkg_postinst() {
- einfo "To mount your MTP device, issue:"
- einfo " /usr/bin/mtpfs <mountpoint>"
- echo
- einfo "To unmount your MTP device, issue:"
- einfo " /usr/bin/fusermount -u <mountpoint>"
-
- if use debug; then
- echo
- einfo "You have enabled debugging output."
- einfo "Please make sure you run mtpfs with the -d flag."
- fi
-}
diff --git a/sys-fs/mtpfs/mtpfs-1.1-r3.ebuild b/sys-fs/mtpfs/mtpfs-1.1-r3.ebuild
deleted file mode 100644
index 5fb9a655bf96..000000000000
--- a/sys-fs/mtpfs/mtpfs-1.1-r3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="A FUSE filesystem providing access to MTP devices"
-HOMEPAGE="https://www.adebenham.com/mtpfs/"
-SRC_URI="https://www.adebenham.com/files/mtp/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug mad"
-
-RDEPEND="dev-libs/glib:2
- >=media-libs/libmtp-1.1.2
- sys-fs/fuse
- mad? (
- media-libs/libid3tag
- media-libs/libmad
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=(AUTHORS NEWS README)
-
-src_prepare() {
- sed -e "/#include <string.h>/ a\
- #include <stdlib.h>" -i mtpfs.h id3read.c || die #implicit
-
- epatch "${FILESDIR}"/${P}-fix-mutex-crash.patch
- epatch "${FILESDIR}"/${P}-unitialized-variable.patch
- epatch "${FILESDIR}"/${P}-wking-patches/*.patch
- epatch "${FILESDIR}"/${P}-g_printf.patch
-}
-
-src_configure() {
- econf $(use_enable debug) \
- $(use_enable mad)
-}
-
-pkg_postinst() {
- einfo "To mount your MTP device, issue:"
- einfo " /usr/bin/mtpfs <mountpoint>"
- echo
- einfo "To unmount your MTP device, issue:"
- einfo " /usr/bin/fusermount -u <mountpoint>"
-
- if use debug; then
- echo
- einfo "You have enabled debugging output."
- einfo "Please make sure you run mtpfs with the -d flag."
- fi
-}