summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/containerd/containerd-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-emulation/containerd/containerd-9999.ebuild b/app-emulation/containerd/containerd-9999.ebuild
index 42467124d22e..345b3fa9b966 100644
--- a/app-emulation/containerd/containerd-9999.ebuild
+++ b/app-emulation/containerd/containerd-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-EGO_PN="github.com/docker/${PN}"
+EGO_PN="github.com/containerd/${PN}"
inherit toolchain-funcs
if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
- MY_PV="${PV/_/-}"
+ MY_PV="${PV/_beta/-beta.}"
EGIT_COMMIT="v${MY_PV}"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64"
+ KEYWORDS="~amd64 ~arm ~ppc64"
inherit golang-vcs-snapshot
fi
@@ -24,17 +24,17 @@ SLOT="0"
IUSE="hardened +seccomp"
DEPEND=""
-RDEPEND=">=app-emulation/runc-1.0.0_rc2
+RDEPEND=">=app-emulation/runc-1.0.0_rc4
seccomp? ( sys-libs/libseccomp )"
S=${WORKDIR}/${P}/src/${EGO_PN}
src_compile() {
- local options=( $(usex seccomp "seccomp") )
+ local options=( $(usex seccomp "seccomp" "") )
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
}
src_install() {
- dobin bin/containerd* bin/ctr
+ dobin bin/containerd{-shim,-stress,} bin/ctr
}