summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/numactl/numactl-2.0.10-r1.ebuild49
-rw-r--r--sys-process/numactl/numactl-2.0.10.ebuild39
2 files changed, 0 insertions, 88 deletions
diff --git a/sys-process/numactl/numactl-2.0.10-r1.ebuild b/sys-process/numactl/numactl-2.0.10-r1.ebuild
deleted file mode 100644
index d01149ba0b0c..000000000000
--- a/sys-process/numactl/numactl-2.0.10-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools eutils toolchain-funcs multilib-minimal
-
-DESCRIPTION="Utilities and libraries for NUMA systems"
-HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
-SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-# ARM lacks the __NR_migrate_pages syscall.
-KEYWORDS="~amd64 -arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE=""
-
-ECONF_SOURCE=${S}
-
-src_prepare() {
- eautoreconf
- epatch "${FILESDIR}"/${PN}-2.0.8-cpuid-pic.patch #456238
-}
-
-src_test() {
- if [ -d /sys/devices/system/node ]; then
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- emake regress2
- else
- ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
- fi
-}
-
-multilib_src_compile() {
- multilib_is_native_abi && default || emake libnuma.la
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
-}
-
-multilib_src_install_all() {
- DOCS=( README TODO CHANGES DESIGN )
- einstalldocs
- # delete man pages provided by the man-pages package #238805
- rm -r "${ED}"/usr/share/man/man[25] || die
-}
diff --git a/sys-process/numactl/numactl-2.0.10.ebuild b/sys-process/numactl/numactl-2.0.10.ebuild
deleted file mode 100644
index 395a4533a203..000000000000
--- a/sys-process/numactl/numactl-2.0.10.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools eutils toolchain-funcs multilib
-
-DESCRIPTION="Utilities and libraries for NUMA systems"
-HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
-SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-# ARM lacks the __NR_migrate_pages syscall.
-KEYWORDS="~amd64 -arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE=""
-
-src_prepare() {
- eautoreconf
- epatch "${FILESDIR}"/${PN}-2.0.8-cpuid-pic.patch #456238
-}
-
-src_test() {
- if [ -d /sys/devices/system/node ]; then
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- emake regress2
- else
- ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
- fi
-}
-
-src_install() {
- DOCS=( README TODO CHANGES DESIGN )
- default
- # delete man pages provided by the man-pages package #238805
- rm -r "${ED}"/usr/share/man/man[25] || die
-}