summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/sgopherd/Manifest1
-rw-r--r--net-misc/sgopherd/sgopherd-18.08.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/sgopherd/Manifest b/net-misc/sgopherd/Manifest
index 8ee05c484adb..977ca010dea1 100644
--- a/net-misc/sgopherd/Manifest
+++ b/net-misc/sgopherd/Manifest
@@ -1 +1,2 @@
DIST sgopherd-17.09.tar.gz 8855 BLAKE2B d79b6f2d6c19e0ec2878ff44c56d739863a74bfc967098d4e51d4b9a723fed587d5d52f78aeb5e915e466f43a28ac443b39e8b79e6a8e8fc82c4c049be7b8cb4 SHA512 7f3ef37d5ec08d21e7945f0327ea50697237461f717a2ce3c5a0fe9c077effe26710013725a59a184564e028f249f7b53087752410600da0f8feaf9cd1b9c7dc
+DIST sgopherd-18.08.tar.bz2 12777 BLAKE2B dde415822f9e4a41463fa6d2622b59adc5676b88cb5b5831ec3396869f6b2bfa4d605b92bd56c24d9aa1b8d4a0198c4f2f46a6141f5f2c913cde1cfb9e99d3db SHA512 830558f2be0763550f0229bfa22524de81c9ea119b2d0f00e465f76ba343d4f488e5595851bbf13697b270d7dc611eafb36a320b6dc2c7d27ad854bd14f4c10d
diff --git a/net-misc/sgopherd/sgopherd-18.08.ebuild b/net-misc/sgopherd/sgopherd-18.08.ebuild
new file mode 100644
index 000000000000..d83915c04118
--- /dev/null
+++ b/net-misc/sgopherd/sgopherd-18.08.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small Gopher Server written in GNU Bash"
+HOMEPAGE="https://www.uninformativ.de/git/sgopherd"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="app-shells/bash
+ sys-apps/sed
+ sys-apps/xinetd"
+
+src_prepare() {
+ # Set default user to run sgopherd
+ sed -i -e '/user/s/http/nobody/' xinetd/xinetd-example.conf || die 'sed failed'
+
+ eapply_user
+}
+
+src_install() {
+ dodoc README
+ doman man8/"${PN}".8
+ dobin "${PN}"
+ insinto /etc/xinetd.d
+ newins xinetd/xinetd-example.conf "${PN}"
+ # TODO: add installation of systemd-related files
+}
+
+pkg_postinst() {
+ elog "${PN} can be launched through xinetd"
+ elog "Configuration options are in /etc/xinetd.d/${PN}"
+}