summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/spiped/spiped-1.6.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-misc/spiped/spiped-1.6.0-r1.ebuild b/net-misc/spiped/spiped-1.6.0-r1.ebuild
index b3ab508eb627..7820531c9cd9 100644
--- a/net-misc/spiped/spiped-1.6.0-r1.ebuild
+++ b/net-misc/spiped/spiped-1.6.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="secure pipe daemon"
HOMEPAGE="http://www.tarsnap.com/spiped.html"
SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
@@ -23,6 +25,10 @@ RDEPEND="
${DEPEND}
!net-mail/qlogtools"
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
src_install() {
dobin "${MY_PN}/${MY_PN}"
dosbin "${PN}/${PN}"