summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/olefile/olefile-0.46.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/olefile/olefile-0.46.ebuild b/dev-python/olefile/olefile-0.46.ebuild
index 10972e2cd7cd..a78fc2a6f0b8 100644
--- a/dev-python/olefile/olefile-0.46.ebuild
+++ b/dev-python/olefile/olefile-0.46.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
inherit distutils-r1
@@ -16,14 +16,19 @@ SLOT="0"
KEYWORDS="alpha amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND=""
BDEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+ doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )"
+
+distutils_enable_tests unittest
+
+python_check_deps() {
+ use doc || return 0
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
python_compile_all() {
if use doc; then
- emake -C doc html
- HTML_DOCS=( doc/_build/html/. )
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/. )
fi
-
}