summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/makepp/files/makepp-2.0.98.5-perl526.patch24
-rw-r--r--dev-util/makepp/makepp-2.0.98.5-r1.ebuild44
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/makepp/files/makepp-2.0.98.5-perl526.patch b/dev-util/makepp/files/makepp-2.0.98.5-perl526.patch
new file mode 100644
index 000000000000..b5ed875b4dcf
--- /dev/null
+++ b/dev-util/makepp/files/makepp-2.0.98.5-perl526.patch
@@ -0,0 +1,24 @@
+diff -ruN makepp-2.0.98.5.orig/config.pl makepp-2.0.98.5/config.pl
+--- makepp-2.0.98.5.orig/config.pl 2017-07-08 21:35:18.257017457 +0200
++++ makepp-2.0.98.5/config.pl 2017-07-08 21:39:06.087026936 +0200
+@@ -19,6 +19,8 @@
+ you on?), get the latest from www.perl.org and install it.
+ EOS
+
++use lib q[.];
++
+ BEGIN { eval { require Mpp::Utils } or warn <<EOS and exit 1 } # avoid BEGIN/die diagnostic
+ Please call this script in the directory where you unpacked it!
+ EOS
+diff -ruN makepp-2.0.98.5.orig/install.pl makepp-2.0.98.5/install.pl
+--- makepp-2.0.98.5.orig/install.pl 2013-07-05 23:02:38.000000000 +0200
++++ makepp-2.0.98.5/install.pl 2017-07-08 21:38:48.441026202 +0200
+@@ -13,6 +13,8 @@
+ #
+ BEGIN { eval { require 5.008 } or exec $^X, 'config.pl' } # Dies with nice message.
+
++use lib q[.];
++
+ BEGIN { eval { require Mpp::Text } or warn <<EOS and exit 1 } # avoid BEGIN/die diagnostic
+ Please call this script in the directory where you unpacked it!
+ EOS
diff --git a/dev-util/makepp/makepp-2.0.98.5-r1.ebuild b/dev-util/makepp/makepp-2.0.98.5-r1.ebuild
new file mode 100644
index 000000000000..d6b300f282ee
--- /dev/null
+++ b/dev-util/makepp/makepp-2.0.98.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV=${PV/_}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="GNU make replacement"
+HOMEPAGE="http://makepp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/2.1/${MY_P}.txz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl:="
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-perl526.patch" )
+
+src_prepare() {
+ # default "all" rule is to run tests :x
+ sed -i '/^all:/s:test::' config.pl || die
+ default
+}
+
+src_configure() {
+ # not an autoconf configure script
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --bindir="${EPREFIX}"/usr/bin \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --mandir="${EPREFIX}"/usr/share/man \
+ --datadir="${EPREFIX}"/usr/share/makepp \
+ || die "configure failed"
+}
+
+src_test() {
+ # work around https://bugzilla.samba.org/show_bug.cgi?id=8728
+ export CCACHE_UNIFY=1
+ ROOT= default
+}