summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild4
-rw-r--r--sys-fs/f2fs-tools/files/f2fs-tools-1.8.0-sysmacros.patch10
2 files changed, 14 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild
index 11d3ad95aa05..fe85240c1de3 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild
@@ -17,6 +17,10 @@ RDEPEND="
selinux? ( sys-libs/libselinux )"
DEPEND="$RDEPEND"
+PATCHES=(
+ "${FILESDIR}"/${P}-sysmacros.patch #623660
+)
+
src_configure() {
#This is required to install to /sbin, bug #481110
econf \
diff --git a/sys-fs/f2fs-tools/files/f2fs-tools-1.8.0-sysmacros.patch b/sys-fs/f2fs-tools/files/f2fs-tools-1.8.0-sysmacros.patch
new file mode 100644
index 000000000000..7ca70222fd5a
--- /dev/null
+++ b/sys-fs/f2fs-tools/files/f2fs-tools-1.8.0-sysmacros.patch
@@ -0,0 +1,10 @@
+--- f2fs-tools-1.8.0/lib/libf2fs.c.orig 2017-07-03 03:01:53.000000000 +0600
++++ f2fs-tools-1.8.0/lib/libf2fs.c 2017-08-17 00:45:01.638979885 +0600
+@@ -16,6 +16,7 @@
+ #include <fcntl.h>
+ #include <mntent.h>
+ #include <time.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <sys/mount.h>
+ #include <sys/ioctl.h>