summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.57.0.116.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 309fdbbb7e55..c4d704555921 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,3 +1,4 @@
DIST skypeforlinux_8.55.0.123-1.x86_64.rpm 107310130 BLAKE2B ec97aeed0159eb91e1e5fa1acf7a9af28e29825e5ec4a422f25115e1daee7e8ad8b5bde11ad65c6b03bd2aecc192f0dfc14fd296ea3a35f077bc4f9e7864c0af SHA512 0bd0ac489f5d1790194146da9299e1e54be289325c0a15f85dfdb4a1a6c8c9a1a21ee36b09603615903d50ac1c389c6d182aa2f3344181503a2e80c2bb76e64c
DIST skypeforlinux_8.55.0.141-1.x86_64.rpm 107313285 BLAKE2B 31c77745a410805a9e39e8ce708edf6735e1676d2c99451dab8faf012d32ecd5082e848ee24b2e1687f4b3a85422261f98f56c569fc48bb3e68e7853ffa16f6e SHA512 db5244abf4c00c7b05cdc54471e4fd235f9743d1f4493b886b021ebad064522a9157483e29c5bcfc6bf5b84905da4969f3997e9a8785fbcc3bca1bd1f1a0544e
DIST skypeforlinux_8.56.0.103-1.x86_64.rpm 107196663 BLAKE2B 987d35fe670e0902db0d43bea1071f24e893613ec80db3fd2d41c1080f3ea1178a449687fe85384dad93955990afadf7144af31aec0f188e7da5d0ff85c51aca SHA512 2760cdcc0afbf626b603d6716fba201b726f58d5be4e17a90fff271769c99c5a9802b27d7c88d4307ddbd5844c0d705c5dd6ecb9834b7b754f2c5d987d6cbed0
+DIST skypeforlinux_8.57.0.116-1.x86_64.rpm 107397354 BLAKE2B 22d1b41201087b3067e89e583734f0b195103dff52f2023e5cc812a977338f2af7eafe5e82bd3f34e263740a1c2791035ee6b75dc077865fa14f1dcc1189b9a6 SHA512 79b5019be9c4cdb28c3dd166aa76128385631e1bc4e31f0b0bfdb0c7af54494987faf4ab3ed05dc9f810b05e07de916d997d5fe4c722aff089e00789394ef3d3
diff --git a/net-im/skypeforlinux/skypeforlinux-8.57.0.116.ebuild b/net-im/skypeforlinux/skypeforlinux-8.57.0.116.ebuild
new file mode 100644
index 000000000000..9811daeb76d3
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.57.0.116.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}