summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/sound_play/Manifest1
-rw-r--r--dev-ros/sound_play/sound_play-0.2.8.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/sound_play/Manifest b/dev-ros/sound_play/Manifest
index aec3da0b587f..3a2fcd27aca0 100644
--- a/dev-ros/sound_play/Manifest
+++ b/dev-ros/sound_play/Manifest
@@ -1 +1,2 @@
DIST audio_common-0.2.7.tar.gz 173982 SHA256 bdffab26cd837b6db65d275dd14de143d1cf056167fc121b213b7403142195c4 SHA512 f765422bdb641e87132e1c9c56ca742d6830fed1d7414b337b61aa242f9955e4138ab13ee4a7786c78ff73f5824748ceb38f98612a7f12dab4dcdc97efa289e3 WHIRLPOOL d1bf17f8bd0e8346d2fff48982c402b0eaa2ea4365b3195e3dd0c4943c93cf1935fdff85a0d2018e43e5074640692c3d72dc72887c86d955dc02c60800e3725b
+DIST audio_common-0.2.8.tar.gz 175497 SHA256 459ce6d834026969b3bec3fc9d59c446d8bd433661138464b90b9f2df38e6f1c SHA512 9a676be8c3c2240c3580facc9cf0e97080e42bfc53651af1308584b6aed32e33d0a4e7457c303290446fe200b2ff366a6136be2b9021e791bd54d81c0a739706 WHIRLPOOL 998e3bd28e18cdbde96693c3715a4eeea80c3d9b0aa4fbaaebaa6ddd926569e800e3e436153aa0854753da00c9bd7c1262d4cd3a04f1298aac05329dd1c6df0d
diff --git a/dev-ros/sound_play/sound_play-0.2.8.ebuild b/dev-ros/sound_play/sound_play-0.2.8.ebuild
new file mode 100644
index 000000000000..c4b4cb101276
--- /dev/null
+++ b/dev-ros/sound_play/sound_play-0.2.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS node that translates commands on a ROS topic (robotsound) into sounds"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib
+ media-libs/gstreamer:0.10
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ app-accessibility/festival
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-base:0.10
+"