summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
index 40deb42b5728..e054182aac83 100644
--- a/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
+++ b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,24 +8,24 @@ inherit gkrellm-plugin
DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times"
HOMEPAGE="http://gkrellsun.sourceforge.net/"
SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
IUSE="nls"
-COMMON_DEPEND="app-admin/gkrellm[X]
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-DEPEND+=" ${COMMON_DEPEND}"
-RDEPEND+=" ${COMMON_DEPEND}"
-
-PLUGIN_SO=src20/gkrellsun.so
PATCHES=(
- "${FILESDIR}/${P}-reenable.patch"
- "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+ "${FILESDIR}"/${P}-reenable.patch
+ "${FILESDIR}"/${P}-Respect-LDFLAGS.patch
)
+PLUGIN_SO=( src20/gkrellsun$(get_modname) )
+
src_compile() {
- use nls && myconf="$myconf enable_nls=1"
+ use nls && local myconf="enable_nls=1"
emake ${myconf}
}