summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/jimtcl/jimtcl-0.74-r1.ebuild13
-rw-r--r--dev-lang/jimtcl/jimtcl-0.75-r1.ebuild6
-rw-r--r--dev-lang/jimtcl/jimtcl-0.75.ebuild13
-rw-r--r--dev-lang/jimtcl/jimtcl-0.76.ebuild6
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild6
5 files changed, 23 insertions, 21 deletions
diff --git a/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild b/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild
index 56008de46ce6..bba26a59e81f 100644
--- a/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild
+++ b/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -31,13 +31,14 @@ src_compile() {
src_install() {
dobin jimsh
- use static-libs && {
+
+ if use static-libs; then
dolib.a libjim.a
- } || {
+ else
dolib.so libjim.so.${PV}
- dosym /usr/$(get_libdir)/libjim.so.${PV} \
- /usr/$(get_libdir)/libjim.so
- }
+ dosym libjim.so.${PV} /usr/$(get_libdir)/libjim.so
+ fi
+
insinto /usr/include
doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h
doins jim-win32compat.h jim-eventloop.h jim-config.h
diff --git a/dev-lang/jimtcl/jimtcl-0.75-r1.ebuild b/dev-lang/jimtcl/jimtcl-0.75-r1.ebuild
index d05b5040644f..3c79869f318e 100644
--- a/dev-lang/jimtcl/jimtcl-0.75-r1.ebuild
+++ b/dev-lang/jimtcl/jimtcl-0.75-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
inherit multiprocessing eutils
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
- inherit git-2
+ inherit git-r3
else
inherit vcs-snapshot
SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
diff --git a/dev-lang/jimtcl/jimtcl-0.75.ebuild b/dev-lang/jimtcl/jimtcl-0.75.ebuild
index 59a5c92d1924..86af1bb8fb99 100644
--- a/dev-lang/jimtcl/jimtcl-0.75.ebuild
+++ b/dev-lang/jimtcl/jimtcl-0.75.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -31,13 +31,14 @@ src_compile() {
src_install() {
dobin jimsh
- use static-libs && {
+
+ if use static-libs; then
dolib.a libjim.a
- } || {
+ else
dolib.so libjim.so.${PV}
- dosym /usr/$(get_libdir)/libjim.so.${PV} \
- /usr/$(get_libdir)/libjim.so
- }
+ dosym libjim.so.${PV} /usr/$(get_libdir)/libjim.so
+ fi
+
insinto /usr/include
doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h
doins jim-win32compat.h jim-eventloop.h jim-config.h
diff --git a/dev-lang/jimtcl/jimtcl-0.76.ebuild b/dev-lang/jimtcl/jimtcl-0.76.ebuild
index a82e24c9b204..3d5515b2e63d 100644
--- a/dev-lang/jimtcl/jimtcl-0.76.ebuild
+++ b/dev-lang/jimtcl/jimtcl-0.76.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
inherit multiprocessing eutils
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
- inherit git-2
+ inherit git-r3
else
inherit vcs-snapshot
SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
index d05b5040644f..3c79869f318e 100644
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
inherit multiprocessing eutils
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
- inherit git-2
+ inherit git-r3
else
inherit vcs-snapshot
SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"