summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lua/penlight/Manifest1
-rw-r--r--dev-lua/penlight/penlight-1.10.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-lua/penlight/Manifest b/dev-lua/penlight/Manifest
index 62c4ae001526..c1784d086715 100644
--- a/dev-lua/penlight/Manifest
+++ b/dev-lua/penlight/Manifest
@@ -1 +1,2 @@
+DIST penlight-1.10.0.tar.gz 413134 BLAKE2B 2091cc6b06f4b64c19f21e25e17495d35d90bc49895b810fb2b31ff99abcd4ac71048d215050e09c27c3954f45cc5a0509886ad66dc17532500238bdf78a926e SHA512 47128b09d1f7d41e8cac7ecc50338b7ebe9095b6768a43f961e27156aac7129e192909e771711e3d2fbd87d3ef475d5934874e0b7ad44f1e40ab4c1cee00736d
DIST penlight-1.9.2.tar.gz 396248 BLAKE2B 2bbbece6e9855e8fc54f22f01e516cdf886782ec9a007a4ffac8ac980d7e0836cd19b8a7659ab1e05331e12b11bdb1c9c7df5e2f03c39965532c381298017035 SHA512 8df26e74f73ccf6dc73546640e1537b63e40357072855f9409e96b2ef8251c25b4653456d1237d5142573618af242e885490aa9750dffb387e4670ed9f3cfa91
diff --git a/dev-lua/penlight/penlight-1.10.0.ebuild b/dev-lua/penlight/penlight-1.10.0.ebuild
new file mode 100644
index 000000000000..9224d13d24b3
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.10.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PN="Penlight"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="https://github.com/Tieske/Penlight"
+SRC_URI="https://github.com/Tieske/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}"
+
+RDEPEND="
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+ ${DEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${DEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+src_prepare() {
+ default
+
+ # This is a demo app, not a real test
+ rm tests/test-app.lua || die
+
+ # Remove test for executing a non-existent command
+ sed -e '/most-likely-nonexistent-command/d' -i tests/test-utils3.lua || die
+}
+
+lua_src_test() {
+ "${ELUA}" run.lua || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins -r lua/pl
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}