summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/chromium/chromium-60.0.3112.78.ebuild7
-rw-r--r--www-client/chromium/chromium-61.0.3159.5.ebuild7
2 files changed, 6 insertions, 8 deletions
diff --git a/www-client/chromium/chromium-60.0.3112.78.ebuild b/www-client/chromium/chromium-60.0.3112.78.ebuild
index a89dd6df1ae3..88f7fd884057 100644
--- a/www-client/chromium/chromium-60.0.3112.78.ebuild
+++ b/www-client/chromium/chromium-60.0.3112.78.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="component-build cups gnome-keyring +gtk3 +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-libvpx +tcmalloc widevine"
+IUSE="component-build cups gnome-keyring +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-libvpx +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -54,6 +54,7 @@ COMMON_DEPEND="
virtual/udev
x11-libs/cairo:=
x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
x11-libs/libX11:=
x11-libs/libXcomposite:=
x11-libs/libXcursor:=
@@ -79,8 +80,6 @@ RDEPEND="${COMMON_DEPEND}
x11-misc/xdg-utils
virtual/opengl
virtual/ttf-fonts
- !gtk3? ( x11-libs/gtk+:2 )
- gtk3? ( x11-libs/gtk+:3 )
selinux? ( sec-policy/selinux-chromium )
tcmalloc? ( !<x11-drivers/nvidia-drivers-331.20 )
widevine? ( www-plugins/chrome-binary-plugins[widevine(-)] )
@@ -402,7 +401,7 @@ src_configure() {
myconf_gn+=" use_cups=$(usex cups true false)"
myconf_gn+=" use_gconf=false"
myconf_gn+=" use_gnome_keyring=$(usex gnome-keyring true false)"
- myconf_gn+=" use_gtk3=$(usex gtk3 true false)"
+ myconf_gn+=" use_gtk3=true"
myconf_gn+=" use_kerberos=$(usex kerberos true false)"
myconf_gn+=" use_pulseaudio=$(usex pulseaudio true false)"
diff --git a/www-client/chromium/chromium-61.0.3159.5.ebuild b/www-client/chromium/chromium-61.0.3159.5.ebuild
index 6cb8b9c4dfb2..8dd11ad4641f 100644
--- a/www-client/chromium/chromium-61.0.3159.5.ebuild
+++ b/www-client/chromium/chromium-61.0.3159.5.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="component-build cups gnome-keyring +gtk3 +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
+IUSE="component-build cups gnome-keyring +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -54,6 +54,7 @@ COMMON_DEPEND="
virtual/udev
x11-libs/cairo:=
x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
x11-libs/libX11:=
x11-libs/libXcomposite:=
x11-libs/libXcursor:=
@@ -79,8 +80,6 @@ RDEPEND="${COMMON_DEPEND}
x11-misc/xdg-utils
virtual/opengl
virtual/ttf-fonts
- !gtk3? ( x11-libs/gtk+:2 )
- gtk3? ( x11-libs/gtk+:3 )
selinux? ( sec-policy/selinux-chromium )
tcmalloc? ( !<x11-drivers/nvidia-drivers-331.20 )
widevine? ( www-plugins/chrome-binary-plugins[widevine(-)] )
@@ -410,7 +409,7 @@ src_configure() {
myconf_gn+=" use_cups=$(usex cups true false)"
myconf_gn+=" use_gconf=false"
myconf_gn+=" use_gnome_keyring=$(usex gnome-keyring true false)"
- myconf_gn+=" use_gtk3=$(usex gtk3 true false)"
+ myconf_gn+=" use_gtk3=true"
myconf_gn+=" use_kerberos=$(usex kerberos true false)"
myconf_gn+=" use_pulseaudio=$(usex pulseaudio true false)"