summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/stepman/Manifest1
-rw-r--r--dev-util/stepman/stepman-0.10.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/stepman/Manifest b/dev-util/stepman/Manifest
index 4d391239337b..4af3e84497a8 100644
--- a/dev-util/stepman/Manifest
+++ b/dev-util/stepman/Manifest
@@ -1,3 +1,4 @@
DIST stepman-0.10.0.tar.gz 3054342 BLAKE2B 8d1d6fc8b4b85c79d535c6162a8b7c5ba15042b6a8334286cdf7ad5d498ee20abecaa1bb9ce9ffe5406891271e23a2e2554bea0b52bbf08df23a2154fdcb4da8 SHA512 1437d5c997e62a9da3beb666a15ac665e18300fad3668ee3acdae30307027bbf16c0d95f649a9a62c6203f3e09f9ec83525a23b3789f09c3707ff1937a7affbe
DIST stepman-0.10.2.tar.gz 3087278 BLAKE2B 224bc6141678d4155474591d7094956ddd230086315ccff8ec2f91bb2d72761f46daa864086a449fb5d79dc2f7ec6f8935fa62a9a5be41a2f0aad9e3de84ca20 SHA512 6b7f1e17ff14e8a0a69056f6a8fa00043b53d818e61603fc2571a42a73e2c88edae1bb233fb734e1796c581c63f7aaf6e91c425525adbb2e1c3429cdc8dfa1e8
DIST stepman-0.10.4.tar.gz 3173321 BLAKE2B b8dcf7eb7ff5afba1fc12b8bf8d4d594b7c86cf26346de053fd8b50010d6a8dbbf55c6e33eef9e9606c672516319b8bacd66eb8a188eb915280f92d027fea253 SHA512 9cd66e45f9a379ad785dc9a35a022d7f9fadeb9707154890d6c6ee17c716d5fcf319dee80c121f9eedc53baef71aaac3a60a6f32135c05113b97f9a5fc7dd299
+DIST stepman-0.10.5.tar.gz 3197451 BLAKE2B f6a4fd2cc0396c5635d7d45a6d88166669dab0bdfed2d53cb8c809c122ee84039660704326c996436d62797db58d46f35bb73af2415e875cf748be9137304280 SHA512 6bd325e1d50d75bf2a38b89c1faf5275914a3a7f00de0d072450253121d9931c4e32ca85300319aaec90ca108223600d3ff1195276df87b11148d4771c642471
diff --git a/dev-util/stepman/stepman-0.10.5.ebuild b/dev-util/stepman/stepman-0.10.5.ebuild
new file mode 100644
index 000000000000..f95a6153f9c0
--- /dev/null
+++ b/dev-util/stepman/stepman-0.10.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Step collection manager for Bitrise CLI"
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ default
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/stepman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/stepman || die "Couldn't compile stepman"
+}
+
+src_test() {
+ pushd _tests/integration > /dev/null || die "Couldn't find integration tests directory"
+ rm update_test.go step_info_test.go setup_test.go || die "Couldn't remove network-dependent tests"
+ popd || die "Couldn't return to ${S} directory"
+ local -x INTEGRATION_TEST_BINARY_PATH="${S}/bin/stepman"
+ GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
+}
+
+src_install() {
+ dobin bin/stepman
+ dodoc README.md
+}