summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/rizin/Manifest1
-rw-r--r--dev-util/rizin/rizin-0.6.2.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/dev-util/rizin/Manifest b/dev-util/rizin/Manifest
index 655cb62f0692..2bfe3632e358 100644
--- a/dev-util/rizin/Manifest
+++ b/dev-util/rizin/Manifest
@@ -1,4 +1,3 @@
-DIST rizin-src-v0.6.2.tar.xz 15409072 BLAKE2B 9e90b07b5a3a5196e68e7c283dcfa214449e9cf1099c90b80a4e3712997bd6f28d5682de01c6f2b6ccafa749e74a4a9a8f7e6e0a313e926779394322a52b14ff SHA512 2b75ebd1c94dd560bb48ffaf8cb56d765ceafd00a3a878f0ae8802a51f398202c501db4c2ec2caefa89a770d4e674743ff5b56fd21f06bf99d9bac4753580dce
DIST rizin-src-v0.6.3.tar.xz 15411052 BLAKE2B 4ddde26dc2541917e1d16f38339bf1467b2148524a1365d739c417857ee856ecb7fbc9210a0f3b562a429c962e31f637bb88a0c0817f42a59868ed3093b0e902 SHA512 031ae1c5b43237d55b3e48d825d4bd9cda16a4a84a47464eb1745a02265a1412e2864345595c0dca7f8ea0cb348fe9760ea424556ff6b915ac8014a7f410b03c
DIST rizin-src-v0.7.1.tar.xz 18941692 BLAKE2B d0384a272e5e8274c970dd9253d84204e8bc026de05ec63fe0252cb6fc9eaee9729bbf03ef3dba100c6e55c58e4a81f7755d7ecb15eebbbb041aa9bfb4c53d30 SHA512 e59b6fd748e551f10169da9a04f7c04ffb017182d3eb5856467df3b167c6d9b387d0faccdb0cd97ee7321ac71179eb7d9a28fa954f34dc028ea8e4259211eac7
DIST rizin-testbins-1203a9a2f51e32337c8434d9f4f7c4543552e271.tar.gz 185572487 BLAKE2B b274a58bebe0123bd8ab7b18a4e88833e7de53133d8f640d00b9efa953cf8ef766582acd5a0f65750ebb273be70d5cc1daf9b700cd6b9bfd4d464cf59ab735ba SHA512 47e8993bea5d7805acb46c1c4e034524fe47d2b0b2471af00d3255f3e853430617658cd6b1f8a4706a748704a52646ec43495f0d4e80f16bce4aaf34e29539a4
diff --git a/dev-util/rizin/rizin-0.6.2.ebuild b/dev-util/rizin/rizin-0.6.2.ebuild
deleted file mode 100644
index 80c181364210..000000000000
--- a/dev-util/rizin/rizin-0.6.2.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-# This is the commit that the CI for the release commit used
-BINS_COMMIT="903588ed69d7717069955322b31dad5e666b338a"
-
-inherit meson python-any-r1
-
-DESCRIPTION="reverse engineering framework for binary analysis"
-HOMEPAGE="https://rizin.re/"
-
-SRC_URI="mirror+https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz
- test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-LICENSE="Apache-2.0 BSD LGPL-3 MIT"
-SLOT="0/${PV}"
-IUSE="test"
-
-# Need to audit licenses of the binaries used for testing
-RESTRICT="test? ( fetch ) !test? ( test )"
-
-# TODO: unbundle dev-libs/blake3
-RDEPEND="
- app-arch/lz4:0=
- app-arch/xz-utils
- >=dev-libs/capstone-5:0=
- dev-libs/libmspack
- dev-libs/libzip:0=
- dev-libs/openssl:0=
- >=dev-libs/tree-sitter-0.19.0
- dev-libs/xxhash
- sys-apps/file
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.4.0-never-rebuild-parser.patch"
- "${FILESDIR}/${PN}-0.5.2-find-tree-sitter-parser.patch"
-)
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_prepare() {
- default
-
- local py_to_mangle=(
- librz/core/cmd_descs/cmd_descs_generate.py
- sys/clang-format.py
- test/fuzz/scripts/fuzz_rz_asm.py
- test/scripts/gdbserver.py
- )
-
- python_fix_shebang "${py_to_mangle[@]}"
-
- # https://github.com/rizinorg/rizin/issues/3459
- sed -ie '/dyld_chained_ptr_arm64e_auth/d' test/unit/test_bin_mach0.c || die
-
- if use test; then
- cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
- cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}" || die
- fi
-}
-
-src_configure() {
- local emesonargs=(
- -Dcli=enabled
- -Duse_sys_capstone=enabled
- -Duse_sys_libmspack=enabled
- -Duse_sys_libzip=enabled
- -Duse_sys_lz4=enabled
- -Duse_sys_lzma=enabled
- -Duse_sys_magic=enabled
- # https://github.com/rizinorg/rizin/issues/3841
- # -Duse_sys_openssl=enabled
- -Duse_sys_tree_sitter=enabled
- -Duse_sys_xxhash=enabled
- -Duse_sys_zlib=enabled
-
- $(meson_use test enable_tests)
- $(meson_use test enable_rz_test)
- )
- meson_src_configure
-}
-
-src_test() {
- # We can select running either unit or integration tests, or all of
- # them by not passing --suite. According to upstream, integration
- # tests are more fragile and unit tests are sufficient for testing
- # packaging, so only run those.
- meson_src_test --suite unit
-}