summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/suricata/suricata-3.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/net-analyzer/suricata/suricata-3.1.ebuild b/net-analyzer/suricata/suricata-3.1.ebuild
index 18a981cc694b..4e48aa6f3b8f 100644
--- a/net-analyzer/suricata/suricata-3.1.ebuild
+++ b/net-analyzer/suricata/suricata-3.1.ebuild
@@ -55,7 +55,6 @@ src_configure() {
$(use_enable af-packet) \
$(use_enable detection) \
$(use_enable nfqueue) \
- $(use_enable redis hiredis) \
$(use_enable test coccinelle) \
$(use_enable test unittests) \
$(use_enable control-socket unix-socket)
@@ -76,6 +75,9 @@ src_configure() {
if use nflog ; then
myeconfargs+=( $(use_enable nflog) )
fi
+ if use redis ; then
+ myeconfargs+=( $(use_enable redis hiredis) )
+ fi
# not supported yet (no pfring in portage)
# if use pfring ; then
# myeconfargs+=( $(use_enable pfring) )