summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
index ed4909097c9b..816c3d9eec8a 100644
--- a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
+++ b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
@@ -4,12 +4,12 @@
EAPI="7"
PHP_EXT_NAME="ps"
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
# Only really build for >=7.0
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
@@ -22,12 +22,13 @@ DEPEND="
php_targets_php7-1? ( dev-libs/pslib )
php_targets_php7-2? ( dev-libs/pslib )
php_targets_php7-3? ( dev-libs/pslib )
+ php_targets_php7-4? ( dev-libs/pslib )
"
RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ps:0[php_targets_php5-6] )"
PHP_EXT_ECONF_ARGS=""
src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
@@ -35,7 +36,7 @@ src_prepare() {
}
src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-pecl-r3_src_install
fi
}