summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lisp/clx/clx-0.7.4-r1.ebuild (renamed from dev-lisp/clx/clx-0.7.4.ebuild)15
-rw-r--r--dev-lisp/clx/clx-9999.ebuild2
-rw-r--r--dev-lisp/clx/metadata.xml7
3 files changed, 12 insertions, 12 deletions
diff --git a/dev-lisp/clx/clx-0.7.4.ebuild b/dev-lisp/clx/clx-0.7.4-r1.ebuild
index 3010ba4bf047..e229aaf004b9 100644
--- a/dev-lisp/clx/clx-0.7.4.ebuild
+++ b/dev-lisp/clx/clx-0.7.4-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit common-lisp-3 eutils
@@ -20,11 +20,12 @@ RDEPEND="!dev-lisp/cl-${PN}"
src_prepare() {
rm -v {exclcmac,sockcl,defsystem,provide,cmudep}.lisp || die
- epatch "${FILESDIR}"/gentoo-fix-asd.patch
- epatch "${FILESDIR}"/gentoo-fix-dep-openmcl.patch
- epatch "${FILESDIR}"/gentoo-fix-unused-vars.patch
- epatch "${FILESDIR}"/gentoo-fix-obsolete-eval-when.patch
- epatch "${FILESDIR}"/gentoo-fix-dynamic-extent-sbcl-1.0.45.patch
+ eapply "${FILESDIR}"/gentoo-fix-asd.patch
+ eapply "${FILESDIR}"/gentoo-fix-dep-openmcl.patch
+ eapply "${FILESDIR}"/gentoo-fix-unused-vars.patch
+ eapply "${FILESDIR}"/gentoo-fix-obsolete-eval-when.patch
+ eapply "${FILESDIR}"/gentoo-fix-dynamic-extent-sbcl-1.0.45.patch
+ eapply_user
}
src_compile() {
diff --git a/dev-lisp/clx/clx-9999.ebuild b/dev-lisp/clx/clx-9999.ebuild
index 000f4485817b..efbfcfbe7378 100644
--- a/dev-lisp/clx/clx-9999.ebuild
+++ b/dev-lisp/clx/clx-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
diff --git a/dev-lisp/clx/metadata.xml b/dev-lisp/clx/metadata.xml
index 6d2b54b52c96..47c41000f413 100644
--- a/dev-lisp/clx/metadata.xml
+++ b/dev-lisp/clx/metadata.xml
@@ -1,10 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>nimiux@gentoo.org</email>
- <name>Chema Alonso</name>
- <description>Maintainer</description>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
</maintainer>
<longdescription lang="en">
CLX provides an implementation of the X Window System protocol to