summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index fad547b4b459..b6760577d086 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1 +1,2 @@
DIST rack-protection-1.5.3.gem 18432 SHA256 b9c08cb17b13c6672ef642cc4855b4c4ba8fcb1f66abc687f03cddf37f106b33 SHA512 9f94f9f25197c3f8227f5c9c9fd2e896e35bfc08d4a20f4dded9c42772f348d16dceda6916429833b498b29c4dbba4dbb31b1a3cf90de597fb6df2de145d655a WHIRLPOOL f1c3b7ddc9dedfefb6d7509bccfd43cf594c7d1234a41fe39ce8740c97d2b1a09c0dd2c8112d1751c93c32380442696c8d5cd7e7e6e1bbaa9ae441601f596883
+DIST rack-protection-2.0.0.gem 15872 SHA256 5574f10cb3fcfe736389f121b868cd3320207aef777a34afb8f2d1226368aa11 SHA512 cce6a8a64c502e4cfec47ae3d76e71aef42b1eec5aa4802a6c443fcb7a8971a99ad9a5b34fea7ae878630faba10d4f5bde4d9a3eb66f63600fcaf02d9ecc0c2e WHIRLPOOL 1cc520cf2105e1d81bd9585c4d719100aba29bab92a802ff4fa13a4e24cc891a8fcc53c5ff45fe9f249933cef6e363f3ea4380ed82c1f2bda404cb3cdebedf9d
diff --git a/dev-ruby/rack-protection/rack-protection-2.0.0.ebuild b/dev-ruby/rack-protection/rack-protection-2.0.0.ebuild
new file mode 100644
index 000000000000..bae4e356cdec
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"