summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/httparty/Manifest2
-rw-r--r--dev-ruby/httparty/httparty-0.13.4.ebuild49
-rw-r--r--dev-ruby/httparty/httparty-0.13.5.ebuild53
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
index 7ed069c5a034..3723447c0110 100644
--- a/dev-ruby/httparty/Manifest
+++ b/dev-ruby/httparty/Manifest
@@ -1,3 +1 @@
-DIST httparty-0.13.4.gem 78848 SHA256 5dea492ff272e8417fc89730c5166944d0a4b41293d7344c1a0de9e804ef9cde SHA512 7f544c3df689e413bfa47798ccc9bea295d00c084ed15da32f105e68ae40bc12c49f3e90e4cde0d147037a94f88f4130143d164e3afd3a069fa8e7b8bb2f8265 WHIRLPOOL e7ac75dce16b3b5e558d58b9519f8fb617265c883e60f780a9abb0c6e31983685990a9b589287fd3cf128be29ee26f70fe305385443487beb3c9d2d1ff93d589
-DIST httparty-0.13.5.gem 78848 SHA256 c9b9a31d80af2e5bc5e2a7c37efc5d8aad4c8d9c58b82f18e4ff37cfef7223d5 SHA512 d8408ea085d71d1a3b80519834173618e283c806ecef25f0a2c6029eee23a0f8e07218ac018dbb884a78e9b0e4e91bad11228112811cefb39e2b8a517fce1880 WHIRLPOOL e7b7b8d299ef4d1cb4dd45189044dbdfa357159f01f9743f35664d1820c9309fac96d6e803ed9bd09f626e5411438ff310dfe3c0bc4803973c53c1808a13e4a3
DIST httparty-0.13.7.gem 81920 SHA256 22c3f4d2681aeb083d4703405799fbc96453ff0d38c3ae3c1e5070dcccdb2f31 SHA512 85402542aceb438d5da3759d06cbe51f3e86301bb28ee3e77587a4eb0918efdda4f97f49271db62b5a9f21431dcdcdc1389d0940629c5f664f694e45b939a567 WHIRLPOOL 8f4855de98a5938e78ca4b989809f2a3cb32d93aa53000e2364def26294d7f3c8ac481f25c8ffdb061774bab6a34a5796dd270f1eaed5374eb439e310c086dc9
diff --git a/dev-ruby/httparty/httparty-0.13.4.ebuild b/dev-ruby/httparty/httparty-0.13.4.ebuild
deleted file mode 100644
index eacb6e256e88..000000000000
--- a/dev-ruby/httparty/httparty-0.13.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# We have a custom test function, but don't null this out so that the
-# deps are still added
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md History"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
-HOMEPAGE="https://jnunemaker.github.com/httparty"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_rdepend '>=dev-ruby/json-1.8:0 >=dev-ruby/multi_xml-0.5.2'
-
-ruby_add_bdepend 'dev-ruby/rspec:3 dev-ruby/fakeweb'
-
-all_ruby_prepare() {
- # Remove bundler
- rm Gemfile || die
- sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
-
- # Avoid test dependency on cucumber. We can't run the features since
- # they depend on mongrel which is no longer packaged.
- sed -i -e '/cucumber/I s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rake spec || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*
-}
diff --git a/dev-ruby/httparty/httparty-0.13.5.ebuild b/dev-ruby/httparty/httparty-0.13.5.ebuild
deleted file mode 100644
index a26eba971324..000000000000
--- a/dev-ruby/httparty/httparty-0.13.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# We have a custom test function, but don't null this out so that the
-# deps are still added
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md History"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
-HOMEPAGE="https://jnunemaker.github.com/httparty"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_rdepend '>=dev-ruby/json-1.8:0 >=dev-ruby/multi_xml-0.5.2'
-
-ruby_add_bdepend 'dev-ruby/rspec:3 dev-ruby/fakeweb'
-
-all_ruby_prepare() {
- # Remove bundler
- rm Gemfile || die
- sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
-
- # Avoid test dependency on cucumber. We can't run the features since
- # they depend on mongrel which is no longer packaged.
- sed -i -e '/cucumber/I s:^:#:' Rakefile || die
-
- # Avoid test dependency on simplecov
- sed -i -e '/simplecov/I s:^:#:' \
- -e '1i require "cgi"' spec/spec_helper.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rake spec || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*
-}