summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/rqt_py_common/Manifest1
-rw-r--r--dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_common/Manifest b/dev-ros/rqt_py_common/Manifest
index 7bb8c4d74093..1ed673ab0569 100644
--- a/dev-ros/rqt_py_common/Manifest
+++ b/dev-ros/rqt_py_common/Manifest
@@ -1 +1,2 @@
+DIST rqt-0.5.0.tar.gz 120992 SHA256 3f62f90db254e111483b9a7cb9d486d0bf07c863b2a987808dc3636ee7004c22 SHA512 5c91fe9bce5a7cb0cdc54b42667488d30c33bd57afd30cc8f2047b91b7aa7b8afd936090bfc76be5dbc8c6497623c1be4340e061503f5a65bc94faaad810597e WHIRLPOOL 1c6ac80ad727a3bc11898036b08fb5d1d1b56fc5dabc4328816018b79709407c3b7cdb095a85fbadff17730b91c33825a77f6756252b527b2c467f5366eade8c
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
diff --git a/dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild b/dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild
new file mode 100644
index 000000000000..bb0ac4b8ba23
--- /dev/null
+++ b/dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for rqt plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"