summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/mini_mime/Manifest1
-rw-r--r--dev-ruby/mini_mime/metadata.xml11
-rw-r--r--dev-ruby/mini_mime/mini_mime-0.1.3.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/mini_mime/Manifest b/dev-ruby/mini_mime/Manifest
new file mode 100644
index 000000000000..6923168b476d
--- /dev/null
+++ b/dev-ruby/mini_mime/Manifest
@@ -0,0 +1 @@
+DIST mini_mime-0.1.3.tar.gz 30971 SHA256 2c936a7b1b6283a6641b9152c5e1b813dfee5ba4f5d35dea7a837d03537ab900 SHA512 3025f79b1a35d8695efd136ecc7cfea1f27f252734188a34e79b3d56780703b4bed115ce511326987bd08a76011394a6a5804355b2647add40581f2f805a923b WHIRLPOOL e37c7e5a250b2b8fee45adb36dcbe7263344257a126774519f4995d5588301e5beb4c858ca80c1111cb056f69ee40c0366f60c7f6e5d88cf0bacaf864a43f946
diff --git a/dev-ruby/mini_mime/metadata.xml b/dev-ruby/mini_mime/metadata.xml
new file mode 100644
index 000000000000..4aa48c66cfd0
--- /dev/null
+++ b/dev-ruby/mini_mime/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">discourse/mini_mime</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/mini_mime/mini_mime-0.1.3.ebuild b/dev-ruby/mini_mime/mini_mime-0.1.3.ebuild
new file mode 100644
index 000000000000..c4335096ed6f
--- /dev/null
+++ b/dev-ruby/mini_mime/mini_mime-0.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="mini_mime.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A lightweight mime type lookup toy"
+HOMEPAGE="https://github.com/discourse/mini_mime"
+SRC_URI="https://github.com/discourse/mini_mime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}