summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/antimicro/antimicro-2.23.ebuild1
-rw-r--r--games-util/antimicro/files/antimicro-2.23-SDL2-include.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/games-util/antimicro/antimicro-2.23.ebuild b/games-util/antimicro/antimicro-2.23.ebuild
index 13efec5688b0..1363ec031a9d 100644
--- a/games-util/antimicro/antimicro-2.23.ebuild
+++ b/games-util/antimicro/antimicro-2.23.ebuild
@@ -31,6 +31,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-linking-errors.patch
"${FILESDIR}"/${PN}-2.23-no-compress-man-page.patch
+ "${FILESDIR}"/${PN}-2.23-SDL2-include.patch
)
src_prepare() {
diff --git a/games-util/antimicro/files/antimicro-2.23-SDL2-include.patch b/games-util/antimicro/files/antimicro-2.23-SDL2-include.patch
new file mode 100644
index 000000000000..a71e9b4b862a
--- /dev/null
+++ b/games-util/antimicro/files/antimicro-2.23-SDL2-include.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/649242
+Thanks-to: Tim Barnes
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -585,6 +585,7 @@
+ endif(WITH_XTEST)
+
+ if(USE_SDL_2)
++ include_directories(${SDL2_INCLUDE_DIRS})
+ list(APPEND LIBS ${SDL2_LIBRARIES})
+ else()
+ list(APPEND LIBS ${SDL_LIBRARIES})