summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-simulation/openrct2/Manifest1
-rw-r--r--games-simulation/openrct2/openrct2-0.1.2.ebuild101
2 files changed, 0 insertions, 102 deletions
diff --git a/games-simulation/openrct2/Manifest b/games-simulation/openrct2/Manifest
index 9aafa6ade4d6..a6c9d3963c3a 100644
--- a/games-simulation/openrct2/Manifest
+++ b/games-simulation/openrct2/Manifest
@@ -1,4 +1,3 @@
-DIST openrct2-0.1.2.tar.gz 6769785 BLAKE2B 0cc6ef6c68c1db6c822dd6038bc2d115f487a52b5891316273ee36db1713913baa2f119dabace88a37c16f87c90b14cf84df75a24b26b22571e98966afd2adbc SHA512 489dac96e1eda1449680f98a4b500eeb7b3f1ffbdaa5a5c701300071eb3a7862c65fa5a81e769083927b95a14914db54307724756a9841cff0c769c9e5471adc
DIST openrct2-0.2.0.tar.gz 6481521 BLAKE2B b3a17d4dd7b0d3e68d4a0a200a81307fa598ac9bafd0636fc2fe62cc0921d1e620cf29a31f2fd5d9258d5b79cd952887e853c005ed719f5990744e9849ad0ee8 SHA512 ac42509ceb52eab20964bf95d7a140dc00d9b4c2569fab1200faff31548f063e209acde29f8ca4ee14858fcf5f6781eebe6d5f7de3d4e01fd43c43ee8905863b
DIST openrct2-objects-v1.0.2.zip 2068705 BLAKE2B 4f291289a7f331bad19080ffc63d204819973682710ea62c3fc66fb9d05b63c267e2146d6c533f59eac3baa9760b85953ae344b6da4bb778e5ccd249f6160525 SHA512 814d52ee5c071f33c17d88bc53711a509d7988ece12381996b3d233b9b46c79739fd2dafbed57f00537b19c78e290e2481d72b2824b5574734f6876a0af0c359
DIST openrct2-objects-v1.0.3.zip 2070513 BLAKE2B 3499b022f1d1f2b05da003f87f5f885de8463ed63d751653b0d8d48e2a339496d84d025eb2e44619012aa76360f6880541a519312e6d339eca862f6274d2b73b SHA512 9012a6337df7abd2743e94e3606266cde306335f33bf4f7869cca90c9c31758806c063b697bc3a6e21af7c733841551f2b29072592850cc51090d58f5f685f99
diff --git a/games-simulation/openrct2/openrct2-0.1.2.ebuild b/games-simulation/openrct2/openrct2-0.1.2.ebuild
deleted file mode 100644
index ae25725577a7..000000000000
--- a/games-simulation/openrct2/openrct2-0.1.2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils gnome2-utils xdg-utils
-
-DESCRIPTION="An open source re-implementation of RollerCoaster Tycoon 2"
-HOMEPAGE="https://openrct2.website/"
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/OpenRCT2/OpenRCT2.git"
- EGIT_BRANCH="develop"
- inherit git-r3
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/OpenRCT2/OpenRCT2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/OpenRCT2-${PV}"
-fi
-
-TSV="${PV}"
-SRC_URI+=" https://github.com/OpenRCT2/title-sequences/releases/download/v${TSV}/title-sequence-v${TSV}.zip -> ${PN}-title-sequence-v${TSV}.zip "
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="libressl +multiplayer opengl test truetype +twitch"
-
-RDEPEND="
- >=dev-libs/jansson-2.5
- >=dev-libs/libzip-1.0
- media-libs/libpng:0=
- media-libs/libsdl2
- media-libs/speexdsp
- multiplayer? (
- libressl? ( dev-libs/libressl:0= )
- !libressl? ( dev-libs/openssl:0= )
- )
- opengl? ( virtual/opengl )
- truetype? (
- media-libs/sdl2-ttf
- media-libs/fontconfig
- )
- twitch? ( net-misc/curl[ssl] )
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
- test? ( dev-cpp/gtest )
-"
-
-src_unpack() {
- if [[ ${PV} == 9999 ]]; then
- git-r3_src_unpack
- else
- unpack ${P}.tar.gz
- fi
-
- mkdir -p "${S}/data/title" || die
- pushd "${S}/data/title" || die
- unpack ${PN}-title-sequence-v${TSV}.zip
- popd || die
-}
-
-src_prepare() {
- sed -i CMakeLists.txt -e 's/-Werror//' || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DDISABLE_HTTP_TWITCH="$(usex !twitch)"
- -DDISABLE_NETWORK="$(usex !multiplayer)"
- -DDISABLE_OPENGL="$(usex !opengl)"
- -DDISABLE_TTF="$(usex !truetype)"
- -DWITH_TESTS="$(usex test)"
- -DDOWNLOAD_TITLE_SEQUENCES=OFF
- -DDISABLE_RCT2_TESTS=ON
- -DSYSTEM_GTEST=ON
- -DBUILD_SHARED_LIBS=ON
- )
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- ewarn ""
- ewarn "You need the original RollerCoaster Tycoon 2 files to play this game."
- ewarn "See: https://github.com/OpenRCT2/OpenRCT2/wiki/Required-RCT2-files#how-to-retrieve"
- ewarn ""
- fi
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}