summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/gcdemu/Manifest1
-rw-r--r--app-cdr/gcdemu/gcdemu-3.2.4.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-cdr/gcdemu/Manifest b/app-cdr/gcdemu/Manifest
index 8af625059d01..e6959795d2e1 100644
--- a/app-cdr/gcdemu/Manifest
+++ b/app-cdr/gcdemu/Manifest
@@ -1 +1,2 @@
DIST gcdemu-3.2.3.tar.bz2 52229 BLAKE2B 9f8d0b6e04b438c0637f42875b144ad4d1a643b8f1216d868040121e417203ffedbf983fec235eb30bf9d11bcfe142e52c1c89966ac3b64442071d0897a9e8bf SHA512 1d31b9edeb111145c7dd438fc645c7513877fe89f78cf262c282bba2d2e7f9a99a8499e607bf00f880186bd4a37a8ebbcc5ba14e1e014254e767a8335396d6e2
+DIST gcdemu-3.2.4.tar.bz2 52209 BLAKE2B 620b1ea8616cf0d7f80954dd00ad1442b55fedafc5ff27ad5aa917e69a803a9629ccadb33ec3fdb2371c464bd484a15e85e00036dee5a67283fbf7e8d64e252c SHA512 920ab87a0b200f3f3983ff878871265084787f1468c042352c319ff3a37131547cc1e981801eefaee1e419ec306b026f7a18da165a17e3ddc6a92998a42e7b41
diff --git a/app-cdr/gcdemu/gcdemu-3.2.4.ebuild b/app-cdr/gcdemu/gcdemu-3.2.4.ebuild
new file mode 100644
index 000000000000..6222ed99b96a
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-3.2.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/gcdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# librsvg for pixbuf-loader
+RDEPEND="${PYTHON_DEPS}
+ app-cdr/cdemu-daemon:0/7
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-base/librsvg:2
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]"
+BDEPEND="${PYTHON_DEPS}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_fix_shebang src/gcdemu
+}
+
+src_configure() {
+ local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}