summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/lxd/lxd-2.17.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-emulation/lxd/lxd-2.17.ebuild b/app-emulation/lxd/lxd-2.17.ebuild
index 910e0b58c9d9..4be344c8be22 100644
--- a/app-emulation/lxd/lxd-2.17.ebuild
+++ b/app-emulation/lxd/lxd-2.17.ebuild
@@ -47,7 +47,7 @@ KEYWORDS="~amd64"
IUSE="+daemon +ipv6 nls test"
-inherit bash-completion-r1 golang-build linux-info systemd user golang-vcs-snapshot
+inherit bash-completion-r1 linux-info systemd user golang-vcs-snapshot
SRC_URI="${ARCHIVE_URI}
${EGO_VENDOR_URI}"
@@ -140,8 +140,10 @@ src_compile() {
src_test() {
if use daemon; then
- # Go native tests should succeed
- golang-build_src_test
+ export GOPATH="${S}"
+ cd "${S}/src/${EGO_PN}" || die "Failed to change to deep src dir"
+
+ emake check
fi
}