summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/patience/files/patience-0.1.1-ghc-8.6.patch20
-rw-r--r--dev-haskell/patience/patience-0.1.1-r1.ebuild26
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/patience/files/patience-0.1.1-ghc-8.6.patch b/dev-haskell/patience/files/patience-0.1.1-ghc-8.6.patch
new file mode 100644
index 000000000000..e844e1d9df5e
--- /dev/null
+++ b/dev-haskell/patience/files/patience-0.1.1-ghc-8.6.patch
@@ -0,0 +1,20 @@
+diff -ru patience-0.1.1/Data/Algorithm/Patience.hs patience-modified/Data/Algorithm/Patience.hs
+--- patience-0.1.1/Data/Algorithm/Patience.hs 2011-08-17 08:08:14.000000000 +0800
++++ patience-modified/Data/Algorithm/Patience.hs 2018-07-11 15:17:45.021338649 +0800
+@@ -15,6 +15,7 @@
+ import Data.Sequence ( (<|), (|>), (><), ViewL(..), ViewR(..) )
+ import qualified Data.Foldable as F
+ import qualified Data.Map as M
++import qualified Data.Map.Strict as MS
+ import qualified Data.IntMap as IM
+
+ import Data.List
+@@ -68,7 +69,7 @@
+ -- Elements whose second component appears exactly once.
+ unique :: (Ord t) => S.Seq (a,t) -> M.Map t a
+ unique = M.mapMaybe id . F.foldr ins M.empty where
+- ins (a,x) = M.insertWith' (\_ _ -> Nothing) x (Just a)
++ ins (a,x) = MS.insertWith (\_ _ -> Nothing) x (Just a)
+
+ -- Given two sequences of numbered "lines", returns a list of points
+ -- where unique lines match up.
diff --git a/dev-haskell/patience/patience-0.1.1-r1.ebuild b/dev-haskell/patience/patience-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..54fcdd486411
--- /dev/null
+++ b/dev-haskell/patience/patience-0.1.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Patience diff and longest increasing subsequence"
+HOMEPAGE="http://hackage.haskell.org/package/patience"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-8.6.patch)