summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/ricochet/Manifest1
-rw-r--r--net-im/ricochet/metadata.xml12
-rw-r--r--net-im/ricochet/ricochet-1.1.4.ebuild56
-rw-r--r--net-im/ricochet/ricochet-9999.ebuild64
4 files changed, 133 insertions, 0 deletions
diff --git a/net-im/ricochet/Manifest b/net-im/ricochet/Manifest
new file mode 100644
index 000000000000..5b3657813636
--- /dev/null
+++ b/net-im/ricochet/Manifest
@@ -0,0 +1 @@
+DIST ricochet-1.1.4.tar.gz 1292671 BLAKE2B 15a71496b01992060fbdbedb0c73365aa250d9e6c4b5bb6223cbcd727a1cf062b1b9cd094d17ae33471e6095a071b1ea6d553a1bb2168974d45486995e204e9b SHA512 9f20fe8e34ea1d8d5b252eee1e164f0a97bf5b3818e864270ea79c0f018b229ec04b1b27acf44415bb646d48b9d1a0ada455a4f77fafdb6e4d21e62292b778a1
diff --git a/net-im/ricochet/metadata.xml b/net-im/ricochet/metadata.xml
new file mode 100644
index 000000000000..6bf484adc0d0
--- /dev/null
+++ b/net-im/ricochet/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lucianposton@pm.me</email>
+ <name>Lucian Poston</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-im/ricochet/ricochet-1.1.4.ebuild b/net-im/ricochet/ricochet-1.1.4.ebuild
new file mode 100644
index 000000000000..b26be1ac4f28
--- /dev/null
+++ b/net-im/ricochet/ricochet-1.1.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ricochet-im/ricochet"
+else
+ SRC_URI="https://github.com/ricochet-im/ricochet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Privacy-focused instant messaging through Tor hidden services"
+HOMEPAGE="https://ricochet.im"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug hardened"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-libs/protobuf:0=
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwidgets:5
+ net-vpn/tor"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_configure() {
+ local qmakeargs=( 'DEFINES+=RICOCHET_NO_PORTABLE' )
+ qmakeargs+=( $(usex debug 'CONFIG+=debug' 'CONFIG+=release') )
+ qmakeargs+=( $(usex hardened 'CONFIG+=hardened' 'CONFIG+=no-hardened') )
+
+ eqmake5 "${qmakeargs[@]}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/net-im/ricochet/ricochet-9999.ebuild b/net-im/ricochet/ricochet-9999.ebuild
new file mode 100644
index 000000000000..b770332effdf
--- /dev/null
+++ b/net-im/ricochet/ricochet-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ricochet-im/ricochet"
+else
+ SRC_URI="https://github.com/ricochet-im/ricochet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Privacy-focused instant messaging through Tor hidden services"
+HOMEPAGE="https://ricochet.im"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug hardened"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-libs/protobuf:0=
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwidgets:5
+ net-vpn/tor"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+
+ # workaround bug https://github.com/ricochet-im/ricochet/issues/582
+ cp contrib/usr.bin.ricochet-apparmor contrib/usr.bin.ricochet
+}
+
+src_configure() {
+ local qmakeargs=( 'DEFINES+=RICOCHET_NO_PORTABLE' )
+ qmakeargs+=( 'DEFINES+=APPARMOR' )
+ qmakeargs+=( $(usex debug 'CONFIG+=debug' 'CONFIG+=release') )
+ qmakeargs+=( $(usex hardened 'CONFIG+=hardened' 'CONFIG+=no-hardened') )
+
+ eqmake5 "${qmakeargs[@]}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}