summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/clang-python/clang-python-10.0.0.9999.ebuild12
-rw-r--r--dev-python/clang-python/clang-python-9.0.0.ebuild12
-rw-r--r--dev-python/clang-python/clang-python-9.0.1.9999.ebuild13
3 files changed, 9 insertions, 28 deletions
diff --git a/dev-python/clang-python/clang-python-10.0.0.9999.ebuild b/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
index 24e14b038ecf..3b6ab496dc37 100644
--- a/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
@@ -4,13 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-inherit git-r3 python-r1
+inherit llvm.org python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/clang/bindings/python
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -28,11 +27,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' clang/bindings/python
-}
-
python_test() {
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-9.0.0.ebuild b/dev-python/clang-python/clang-python-9.0.0.ebuild
index ad10831f6e23..6796e58d1b11 100644
--- a/dev-python/clang-python/clang-python-9.0.0.ebuild
+++ b/dev-python/clang-python/clang-python-9.0.0.ebuild
@@ -4,13 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-inherit python-r1
+inherit llvm.org python-r1
-MY_P=cfe-${PV/_/}.src
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
-S=${WORKDIR}/${MY_P}/bindings/python
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -28,11 +27,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-src_unpack() {
- einfo "Unpacking parts of ${MY_P}.tar.xz ..."
- tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
-}
-
python_test() {
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-9.0.1.9999.ebuild b/dev-python/clang-python/clang-python-9.0.1.9999.ebuild
index 45d2a38e5e59..3b6ab496dc37 100644
--- a/dev-python/clang-python/clang-python-9.0.1.9999.ebuild
+++ b/dev-python/clang-python/clang-python-9.0.1.9999.ebuild
@@ -4,14 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-inherit git-r3 python-r1
+inherit llvm.org python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-EGIT_BRANCH="release/9.x"
-S=${WORKDIR}/${P}/clang/bindings/python
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -29,11 +27,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' clang/bindings/python
-}
-
python_test() {
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}