summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/ircstats/ircstats-1.2.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/net-irc/ircstats/ircstats-1.2.ebuild b/net-irc/ircstats/ircstats-1.2.ebuild
index d50345072372..c893f91fb286 100644
--- a/net-irc/ircstats/ircstats-1.2.ebuild
+++ b/net-irc/ircstats/ircstats-1.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P="IRCStats-${PV}"
@@ -14,10 +14,9 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-S="${WORKDIR}"/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_compile() {
- default
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
@@ -29,6 +28,6 @@ src_install() {
}
pkg_postinst() {
- elog "The IRCStats files have been installed in /usr/share/ircstats"
- elog "You can find an example ircstats.cfg in /usr/share/doc/${PF}"
+ elog "The IRCStats files have been installed in ${EROOT}/usr/share/ircstats"
+ elog "You can find an example ircstats.cfg in ${EROOT}/usr/share/doc/${PF}"
}